Package Details: barracudavpn 5.1.4-3

Git Clone URL: https://aur.archlinux.org/barracudavpn.git (read-only, click to copy)
Package Base: barracudavpn
Description: Barracuda VPN Client for Linux
Upstream URL: https://campus.barracuda.com/product/networkaccessclient
Keywords: barracudavpn vpn
Licenses: custom:BarracudaVPN
Submitter: RoMarQ
Maintainer: RoMarQ
Last Packager: RoMarQ
Votes: 2
Popularity: 0.117305
First Submitted: 2020-02-08 01:09
Last Updated: 2020-06-03 00:21

Latest Comments

« First ‹ Previous 1 2

RoMarQ commented on 2020-06-01 00:12

@firebone, @theokonos

The package was updated to version 5.1.4

Troubleshooting: startmanager.go:574: [/bin/sh -c export GIO_LAUNCHED_DESKTOP_FILE_PID=$$;exec gnome-terminal -e env TERM=xterm /usr/bin/barracudavpn]: exit status 127

This happened to me on deepin.

The solution is to run barracudavpn from terminal: TERM=xterm /usr/bin/barracudavpn

RoMarQ commented on 2020-05-26 00:58

Hello @firebone,

Sorry for the late response, mails were being categorized as spam.

I will try to find some time next weekend to update the package. In the meanwhile do as @theokonos suggested.

firebone commented on 2020-05-21 20:18

Thank you @theokonos. If I hear someting from the maintainer I will let you know. As for now still radiosilence.

Thank you for your explanation, I got it installed. :)

theokonos commented on 2020-05-21 13:15

@firebone

I got the latest 5.14 version of the VPN client working in Manjaro by running debtap with the Linux package provided by Barracuda.

If you're not already familiar, debtap(AUR) is a package that essentially digs into the source contents of a Debian package file, extracts it and generates a PKGBUILD file that can be understood by Arch along with a re-packaged .tar.xz file that can be directly installed by pacman.

To get it working, you'll need to log into your Barracuda cloud account and go here: https://login.barracudanetworks.com/support/ng_downloads then download the .tar.gz build for Linux.

Next extract the .tar file within it and then the .deb package within that.

After you have debtap installed, run debtap -u to update its database. Then run debtap barracudavpn_5.1.4_amd64.deb and answer all the questions with either no info or the default answers.

Finally run pacman -U barracudavpn-5.1.4-1-x86_64.pkg.tar.xz and pacman will perform a normal offline installation of the package.

However, be warned -- if you're running KDE, there's currently a bug #421374 that is causing any applications that rely on Konsole, including Barracuda VPN, to fail when being launched from a shortcut. It's supposed to be fixed in a new build coming out soon, but for now you'll need to launch the Barracuda VPN from a terminal using env TERM=xterm /usr/bin/barracudavpn

Hope that helps! Theo

theokonos commented on 2020-05-21 12:42

@firebone I appreciate the info -- please let me know if you hear from them!

firebone commented on 2020-05-20 19:42

@theokonos I already mailed the maintainer and flagged it as out of date as there are newer versions available. I am pretty new to (arch) linux so building packages myself is not something I have done before. As of so far I have had no response from the maintainer and no reply to my email.

theokonos commented on 2020-05-20 13:25

@firebone I'm getting the same error, with the same pkgver version.

firebone commented on 2020-04-19 20:03

I get an error when I try to install it from the AUR.

failed to parse barracudavpn: Line 4: key "pkgver" can not occur after pkgname: pkgver = 5.0.2.7