Package Details: bareos-storage-python-plugin 18.2.6-3

Git Clone URL: https://aur.archlinux.org/bareos.git (read-only)
Package Base: bareos
Description: Bareos - Backup Archiving REcovery Open Sourced - Python plugin for storage daemon
Upstream URL: http://www.bareos.org
Keywords: Backup bacula bareos
Licenses: AGPL3
Groups: bareos
Submitter: AlD
Maintainer: spradlim (mfulz)
Last Packager: mfulz
Votes: 11
Popularity: 0.39
First Submitted: 2014-07-23 09:45
Last Updated: 2019-12-04 18:09

Latest Comments

1 2 3 4 5 6 ... Next › Last »

FieldOfClay commented on 2019-12-07 09:00

It still fails for me during the cmake checks, unless I include ceph as a makedepends. It seems that it is still looking for ceph, somewhere. I haven't been able to figure out where.
This is on a machine that only needs bareos-filedaemon and bareos-common.

mfulz commented on 2019-12-04 18:12

Hi Kai,

I've added the mkdir -p thanks for the hint.

ceph is only needed for the bareos-backend-ceph afaik, which is not inlcuded here?

php is included as dependency for the webui package, which is correct in my opinion?

balticer commented on 2019-11-25 19:39

Hello,

a few suggestions:

  • change "mkdir build" to "mkdir -p build" in build() or remove "build" directory after package is build to allow rebuilding without errors
  • "community/ceph" or "community/ceph-libs" is needed, at least as build dependency?!
  • PHP is needed, at least as build dependency?!

regards Kai

mfulz commented on 2019-10-23 11:24

@spradlim: Thanks.

The bareos is updated to 18.2.6 and working for me. Any feedback is welcome :)

I've added also bareos-web-ui but I've to rename it because of this one: https://aur.archlinux.org/packages/bareos-webui which is not working at all. Hopefully this guy will throw it away so we can take it over.

spradlim commented on 2019-10-23 04:57

Mfulz I added you

mfulz commented on 2019-10-22 23:38

I'd like to take it over. Working on a 18.2.6 build atm and should be ready the next days.

spradlim commented on 2019-07-02 14:38

Obviously, I no longer have time to maintain this package. Anyone, else want to maintain this package?

malus commented on 2019-06-26 21:50

Hello spradlim, could you please add 'git' to makedepends? I think it is needed by all involved packages. Thanks :)

spradlim commented on 2019-04-23 13:37

@impatt Upstream he puts it in libbareossd.so in bareos-common so I would put it there.

impatt commented on 2019-04-23 08:01

@deep_thought: Two things: Maybe this patch will be useful:

--- /tmp/PKGBUILD 2019-04-23 11:50:04.845864401 +0500 +++ /tmp/PKGBUILD_ 2019-04-23 12:22:50.103145212 +0500 @@ -28,7 +28,7 @@ pkgdesc="Bareos - Backup Archiving REcovery Open Sourced" url="http://www.bareos.org" license=('AGPL3') -makedepends=(acl bash cmake gcc-libs glibc jansson libcap libmariadbclient lsb-release lzo mtx openssl postgresql-libs python python2 readline sqlite3 zlib) +makedepends=(acl bash cmake gcc-libs glibc jansson libcap libmariadbclient lsb-release lzo mtx openssl postgresql-libs python python2 readline sqlite3 zlib patch gcc make pkg-config fakeroot) makedepends_x86_64=(ceph) makedepends_armv7h=(ceph) makedepends_aarch64=(ceph)

Question: when installing packages on ARMv7, a conflict of files is detected: error: failed to commit transaction (conflicting files) /usr/lib/bareos/libbareossd.so exists in both 'bareos-common' and 'bareos-storage' Which package would it be more logical to attribute /usr/lib/bareos/libbareossd.so when building packages?

Thank you.