Package Details: balena-cli 12.44.9-1

Git Clone URL: https://aur.archlinux.org/balena-cli.git (read-only, click to copy)
Package Base: balena-cli
Description: balena.io command line interface
Upstream URL: https://balena.io/
Licenses: Apache
Replaces: resin-cli
Submitter: imrehg
Maintainer: gin078
Last Packager: gin078
Votes: 7
Popularity: 0.54
First Submitted: 2018-11-08 14:54
Last Updated: 2021-04-14 13:38

Latest Comments

gin078 commented on 2021-04-12 14:58

@mdx as noted upstream, this package requires npm <7: https://github.com/balena-io/balena-cli/blob/master/package.json#L88

Anonymous comment on 2021-03-23 12:23

Why does this package depend on npm4 instead of npm? Edit: switched to balena-cli-bin package.

sthysel commented on 2021-02-26 04:14

This package expects me downgrade to nodejs-lts-dubnium

nodejs-lts-dubnium and nodejs are in conflict. Remove nodejs

How can I make use of this package in multi nodejs environment ?

gin078 commented on 2020-07-01 19:02

@anonumoouse according to https://wiki.archlinux.org/index.php/Arch_User_Repository#How_to_get_a_PKGBUILD_into_the_community_repository? a trusted user (TU) will need to adopt the package to get it into the community repository. Since this package has only 3 votes at the moment, I doubt any TU will be willing to adopt it at this point (that FAQ mentions a minimum of 10 votes generally).

anonumoouse commented on 2020-07-01 17:10

Is there a reason none of the balena packages are in the arch linux community pkg repos? It's open source and popular. This package in particular takes forever to build on its very frequent updates. Wouldn't that be avoided if it was a normal arch pkg?

ulyssesrr commented on 2020-03-08 17:44

Just built it with Node v13, it's been supported since 11.25.10, see: https://github.com/balena-io/balena-cli/issues/1591

jaantoots commented on 2019-11-20 22:44

The package (actually a dependecy ext2fs) doesn't build with Node 13. This should be reflected in the nodejs dependency version restriction (`nodejs<13.0.0') until it is resolved upstream.

jaantoots commented on 2019-09-29 14:04

git is missing from makedepends. package fails with npm error output:

npm ERR! code ENOENT
npm ERR! syscall spawn git
npm ERR! path git
npm ERR! errno ENOENT
npm ERR! enoent Error while executing:
npm ERR! enoent undefined ls-remote -h -t ssh://git@github.com/balena-io-library/node-unzip-2.git
...