Package Details: backblaze-b2 2.5.0-2

Git Clone URL: https://aur.archlinux.org/backblaze-b2.git (read-only, click to copy)
Package Base: backblaze-b2
Description: Backblaze B2 Command Line Client
Upstream URL: https://github.com/Backblaze/B2_Command_Line_Tool
Keywords: archive backblaze backup cloud storage
Licenses: MIT
Submitter: 2bluesc
Maintainer: 2bluesc
Last Packager: 2bluesc
Votes: 22
Popularity: 0.061269
First Submitted: 2015-10-29 06:31
Last Updated: 2021-07-10 03:04

Latest Comments

1 2 3 4 Next › Last »

Kage-Yami commented on 2021-07-08 10:29

Looks like while the last issue I reported has been resolved, we've had a regression with the setuptools_scm dependency - this is back to failing to build in environments without pip, similar to what was happening back in April, as it looks like the requirement of <6.0 was removed in the last AUR update, without also patching out the requirement from the source code.

samhh commented on 2021-07-03 11:19

Is anyone else finding that as of 2.5.0 of this package Duplicity isn't working with Backblaze?

BackendException: Could not initialise backend: No module named 'b2sdk.download_dest'

toddejohnson commented on 2021-06-30 16:21

For chroot build it needs makedepends python-pip too. Thank you for maintaining this PKGBUILD!

Hoek commented on 2021-06-23 21:16

Today's python-setuptools-scm 6.0.1 release broke this package:

error: could not find all required packages:
    python-setuptools-scm<6.0 (wanted by: backblaze-b2)

Kage-Yami commented on 2021-06-14 06:54

Hi again, looks like the packaging for this might be broken again (at least in some scenarios)...

My builds for this have been working fine up until two days ago (12-Jun). However, starting yesterday, running the package has started to fail (so not sure if the builds will still fail or not, as my CI pipeline doesn't get that far).

The relevant parts of the error (at least as far as I can glean) is:

pkg_resources.ContextualVersionConflict: (docutils 0.17 (/usr/lib/python3.9/site-packages), Requirement.parse('docutils==0.16'), {'b2'})
 -- snip --
pkg_resources.DistributionNotFound: The 'docutils==0.16' distribution was not found and is required by b2

Full error can be seen here: https://gitlab.com/Kage-Yami/arch-packages/-/jobs/1342703278

Looking in the requirements.txt for the upstream repository, it contains docutils==0.16, but this package has listed docutils>=0.16 as a dependency, allowing 0.17 to be installed instead.

So as I understand it, the solution is to switch this package to depend on docutils==0.16 instead.

Looks like Arch only started packaging 0.17 two days ago, which would explain the timing of this issue (the docutils upstream had released 0.17 in April)

Kage-Yami commented on 2021-04-04 17:46

Yup, looks like that did the trick. Thanks~!

2bluesc commented on 2021-04-04 17:44

@Kage-Yami try now. Should work!

Kage-Yami commented on 2021-04-04 17:38

Looks like the same issue as we found on python-b2sdk is affecting this package as well; turns out the timing of my builds were such that the new version of this wasn't visible yet when I originally reported, but a later build then failed.

Same pip error:

subprocess.CalledProcessError: Command '['/usr/sbin/python', '-m', 'pip', '--disable-pip-version-check', 'wheel', '--no-deps', '-w', '/tmp/tmpl6ohluqj', '--quiet', 'setuptools_scm<6.0']' returned non-zero exit status 1.

ipha commented on 2021-04-04 14:49

New dep python-docutils is needed as of version 2.2+

Hoek commented on 2020-10-17 16:24

@2bluesc sorry I was mistaken. Somehow building the package using yay caused the build to error out because python-tqdm and python-logfury were missing, but I see they're in the package dependencies. I can't reproduce after reinstalling, everything seems to be fine :/