Package Details: azote 1.8.1-2

Git Clone URL: https://aur.archlinux.org/azote.git (read-only, click to copy)
Package Base: azote
Description: Wallpaper & color manager for Sway, i3 and other WMs
Upstream URL: https://github.com/nwg-piotr/azote
Licenses: GPL3
Submitter: nwg
Maintainer: nwg
Last Packager: nwg
Votes: 4
Popularity: 0.045715
First Submitted: 2019-06-15 23:31
Last Updated: 2020-12-04 07:49

Dependencies (17)

Required by (0)

Sources (1)

Latest Comments

nwg commented on 2020-07-07 23:15

@brandflake11 - please submit an issue: https://github.com/nwg-piotr/azote/issues

Please attach the output on the xrandr command on your machine.

brandflake11 commented on 2020-07-07 19:10

With the most recent azote, I get this when trying to run it:

 Traceback (most recent call last):
  File "main.py", line 1812, in <module>
    sys.exit(main())
  File "main.py", line 1797, in main
    set_env(lang)  # detect displays, check installed modules, set paths and stuff
  File "/usr/lib/python3.8/site-packages/azote/tools.py", line 251, in set_env
    common.displays = check_displays()
  File "/usr/lib/python3.8/site-packages/azote/tools.py", line 117, in check_displays
    w_h = res[i].split('x')
IndexError: list index out of range

nwg commented on 2019-06-22 10:28

@HoaS I haven't thought about it, as it's always installed on all of my machines. Thanks for the report, I'll update PKGBUILD.

[edit] added in 0.1.1-2

HoaS commented on 2019-06-22 10:09

I think you need to add gtk3 as a depends, the program fails otherwise:

Traceback (most recent call last):
  File "main.py", line 26, in <module>
    gi.require_version('Gtk', '3.0')
  File "/usr/lib/python3.7/site-packages/gi/__init__.py", line 129, in require_version
    raise ValueError('Namespace %s not available' % namespace)
ValueError: Namespace Gtk not available