Package Details: awesome-git 4.3.956.g95558ac91-1

Git Clone URL: https://aur.archlinux.org/awesome-git.git (read-only, click to copy)
Package Base: awesome-git
Description: Highly configurable framework window manager
Upstream URL: http://awesome.naquadah.org/
Licenses: GPL2
Conflicts: awesome
Provides: awesome, notification-daemon
Submitter: noonov
Maintainer: trollixx (actionless)
Last Packager: actionless
Votes: 216
Popularity: 1.23
First Submitted: 2007-11-22 16:01
Last Updated: 2021-03-31 06:21

Required by (60)

Sources (1)

Pinned Comments

trollixx commented on 2016-12-27 08:30

Please do not flag this package out-of-date unless it fails to build due to upstream changes.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

suffer commented on 2021-03-29 21:25

@raven2cz 5.4 is Arch's default Lua (and has been for a while), Awesome still requires 5.3. They made changes to the build system to make it easier to build against non-default versions of Lua.

raven2cz commented on 2021-03-28 10:14

The PKGBUILD needs update. According to https://github.com/awesomeWM/awesome/pull/3279

https://www.reddit.com/r/awesomewm/comments/mexdzf/awesomegit_cannot_be_compiled_from_the_morning/

The lua 5.4 is default now. The build has to use new build option. Sed is cannot be used now.

suffer commented on 2021-03-28 09:54

Does not build. Upstream changes: https://github.com/awesomeWM/awesome/pull/3279

Hkyx commented on 2020-09-11 15:49

it don't fail but it put some breaking changes since the last update like some apps as MS Teams got a black screen when sharing a screen.

aDogCalledSpot commented on 2020-08-06 12:42

lgi currently only has experimental lua 5.4 support, so we should make this package use lua 5.3 until this is fixed

Night commented on 2020-08-06 12:08

I seem to get this error when I build now (it's just stopped working (Upstream related?)):

[ 0%] Building C object CMakeFiles/test-gravity.dir/tests/test-gravity.c.o make[2]: No rule to make target '/usr/lib/liblua.so.5.3', needed by 'test-gravity'. Stop. make[1]: [CMakeFiles/Makefile2:499: CMakeFiles/test-gravity.dir/all] Error 2 make: *** [Makefile:149: all] Error 2 ==> ERROR: A failure occurred in build().

I think it might be because Lua has been upgraded in the main repos to 54 now?: https://www.archlinux.org/packages/extra/x86_64/lua/

I can see that there's a 5.4 version coming along soon maybe https://github.com/awesomeWM/awesome/tree/lua54

brneor commented on 2019-01-29 16:57

Why is this package older than stable? It wasn't supposed to be the "beta" version?

actionless commented on 2017-06-04 01:35

pinning lua penlight to 1.4.1 also helps

ahrs commented on 2017-04-09 22:43

This failed to build at the documentation generation stage for me. Passing `-DGENERATE_DOC=0` to cmake allowed the build to continue.

whooper commented on 2017-01-08 16:54

/usr/lib/libharfbuzz.so.0: undefined reference to `FT_Get_Var_Blend_Coordinates'
collect2: error: ld returned 1 exit status
make[2]: *** [CMakeFiles/awesome.dir/build.make:1113: awesome] Error 1
make[1]: *** [CMakeFiles/Makefile2:134: CMakeFiles/awesome.dir/all] Error 2
make: *** [Makefile:128: all] Error 2

fails to build with this error. any solution?