Package Details: autokey-gtk 0.95.10-4

Git Clone URL: https://aur.archlinux.org/autokey.git (read-only, click to copy)
Package Base: autokey
Description: A desktop automation utility for Linux and X11 - GTK frontend
Upstream URL: https://github.com/autokey/autokey
Licenses: GPL3
Conflicts: autokey-qt
Submitter: dark-saber
Maintainer: yochananmarqos
Last Packager: yochananmarqos
Votes: 59
Popularity: 0.37
First Submitted: 2019-02-12 12:21
Last Updated: 2021-04-07 17:34

Pinned Comments

yochananmarqos commented on 2020-12-12 15:13

PSA: You may need to uninstall the old autokey package before you can upgrade to autokey-common + autokey-gtk / autokey-qt due to conflicting files.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

hicklemon commented on 2021-04-12 14:26

Hello,

A recent update seems to have created some conflicts with autokey-common and autokey-gtk if the user has pyenv installed.

In order to get around this, I cleaned up my PATH and pyenv vars temporarily:

PATH=/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl

unset PYENV_ROOT
unset PYENV_SHELL
unset PYENV_VIRTUALENVWRAPPER_PYENV_VERSION

yay -Syy autokey-gtk

This seems to have worked

Ray commented on 2021-01-16 21:19

I just found this AUR and used it to replace old Autokey that no longer functioned. Autokey is a critical application for so many of us. I hope development will continue. Thank you for updating this package.

buzuddha commented on 2020-12-17 02:32

Gotcha. Was in the autokey directory. Just didn't realize I needed to add the version numbers and extension.

 $ sudo pacman -U --asdeps autokey-common-0.95.10-2-x86_64.pkg.tar.zst 

seemed to do it. Same worked for for autokey-gtk.

Thanks for your help!

yochananmarqos commented on 2020-12-17 02:28

@buzuddha: You already built the packages, now go to the $PKGDEST and install them. Also see man makepkg and read the Arch wiki page.

buzuddha commented on 2020-12-17 02:23

Hmmm...

[user@Squarch autokey]$ makepkg -s
==> ERROR: The package group has already been built. (use -f to overwrite)
[user@Squarch autokey]$ sudo pacman -U --asdeps autokey-common
[sudo] password for user: 
loading packages...
error: 'autokey-common': could not find or read package

I get the same with

makepkg -sf
and then the pacman install. Any thoughts?

yochananmarqos commented on 2020-12-17 01:55

@buzuddha: Build the package without -i, then install manually after:

sudo pacman -U --asdeps autokey-common

Then either:

sudo pacman -U autokey-gtk

Or:

sudo pacman -U autokey-qt

buzuddha commented on 2020-12-17 01:39

I'm having an issue with updating autokey. The long story is here: https://bbs.archlinux.org/viewtopic.php?pid=1943997#p1943997

The short story is :: autokey-gtk and autokey-qt are in conflict during makepkg -si of auotkey-common. Anything I'm missing?

yochananmarqos commented on 2020-12-16 23:07

@zhimsel: Good catch, fixed.

zhimsel commented on 2020-12-16 22:55

FYI, the PKGBUILD as-is is broken (at least on my system). All the rm commands for the pycache files need to be rm -f. Those file don't exist (on my system), so the plain rm command fails.

https://gist.github.com/zhimsel/2c794f552d19e175f7fb8f5854cfa85e

yochananmarqos commented on 2020-12-12 15:13

PSA: You may need to uninstall the old autokey package before you can upgrade to autokey-common + autokey-gtk / autokey-qt due to conflicting files.