Package Details: autofirma 1.6.5-1

Git Clone URL: https://aur.archlinux.org/autofirma.git (read-only)
Package Base: autofirma
Description: Spanish Government digital signature client
Upstream URL: http://firmaelectronica.gob.es
Licenses: GPL, EUPL
Submitter: migrev
Maintainer: migrev
Last Packager: migrev
Votes: 14
Popularity: 0.927625
First Submitted: 2017-04-17 07:28
Last Updated: 2019-05-10 11:10

Latest Comments

« First ‹ Previous 1 2 3

timofonic commented on 2017-09-13 05:12

Please, I need this to register to a FP...


~  pacaur autofirma s  Wed 13 Sep 2017 05:17:16 AM CEST
[sudo] password for timofonic:
error: no operation specified (use -h for help)
!  ~  pacaur -S autofirma 3440ms  Wed 13 Sep 2017 07:10:07 AM CEST
:: Package autofirma not found in repositories, trying AUR...
:: resolving dependencies...
:: looking for inter-conflicts...

AUR Packages (1) autofirma-1.5-3

:: Proceed with installation? [Y/n] y
:: Retrieving package(s)...
Cloning into 'autofirma'...
remote: Counting objects: 4, done.
remote: Compressing objects: 100% (4/4), done.
remote: Total 4 (delta 0), reused 0 (delta 0)
Unpacking objects: 100% (4/4), done.
:: View autofirma PKGBUILD? [Y/n] n
:: Checking autofirma integrity...
==> Making package: autofirma 1.5-3 (Wed Sep 13 07:10:25 CEST 2017)
==> Retrieving sources...
-> Downloading AutoFirma_Linux.zip...
% Total % Received % Xferd Average Speed Time Time Time Current
Dload Upload Total Spent Left Speed
100 35.6M 100 35.6M 0 0 2806k 0 0:00:13 0:00:13 --:--:-- 2679k
==> Validating source files with md5sums...
AutoFirma_Linux.zip ... Passed
==> Making package: autofirma 1.5-3 (Wed Sep 13 07:10:39 CEST 2017)
==> WARNING: Skipping dependency checks.
==> Retrieving sources...
-> Found AutoFirma_Linux.zip
==> WARNING: Skipping all source file integrity checks.
==> Removing existing $srcdir/ directory...
==> Extracting sources...
-> Extracting AutoFirma_Linux.zip with bsdtar
==> Starting prepare()...
==> Sources are ready.
:: Building autofirma package(s)...
==> Making package: autofirma 1.5-3 (Wed Sep 13 07:10:40 CEST 2017)
==> Checking runtime dependencies...
==> Installing missing dependencies...
resolving dependencies...
looking for conflicting packages...

Packages (2) jre8-openjdk-headless-8.u144-1 jre8-openjdk-8.u144-1

Total Download Size: 26.08 MiB
Total Installed Size: 95.87 MiB

:: Proceed with installation? [Y/n]
:: Retrieving packages...
jre8-openjdk-headle... 25.9 MiB 7.80M/s 00:03 [######################] 99%
jre8-openjdk-8.u144... 26.1 MiB 7.63M/s 00:03 [######################] 100%
(2/2) checking keys in keyring [######################] 100%
(2/2) checking package integrity [######################] 100%
(2/2) loading package files [######################] 100%
(2/2) checking for file conflicts [######################] 100%
(2/2) checking available disk space [######################] 100%
:: Processing package changes...
(1/2) installing jre8-openjdk-headless [######################] 100%
Default Java environment is already set to 'java-7-openjdk'
See 'archlinux-java help' to change it
Optional dependencies for jre8-openjdk-headless
java-rhino: for some JavaScript support
(2/2) installing jre8-openjdk [######################] 100%
Default Java environment is already set to 'java-7-openjdk'
See 'archlinux-java help' to change it
when you use a non-reparenting window manager,
set _JAVA_AWT_WM_NONREPARENTING=1 in /etc/profile.d/jre.sh
Optional dependencies for jre8-openjdk
icedtea-web: web browser plugin + Java Web Start
alsa-lib: for basic sound support [installed]
gtk2: for the Gtk+ look and feel - desktop usage [installed]
java-openjfx: for JavaFX GUI components support
:: Running post-transaction hooks...
(1/1) Arming ConditionNeedsUpdate...
==> Checking buildtime dependencies...
==> WARNING: Using existing $srcdir/ tree
==> Entering fakeroot environment...
==> Starting package()...
Exception in thread "main" java.lang.UnsupportedClassVersionError: es/gob/afirma/standalone/configurator/AutoFirmaConfigurator : Unsupported major.minor version 52.0
at java.lang.ClassLoader.defineClass1(Native Method)
at java.lang.ClassLoader.defineClass(ClassLoader.java:803)
at java.security.SecureClassLoader.defineClass(SecureClassLoader.java:142)
at java.net.URLClassLoader.defineClass(URLClassLoader.java:442)
at java.net.URLClassLoader.access$100(URLClassLoader.java:64)
at java.net.URLClassLoader$1.run(URLClassLoader.java:354)
at java.net.URLClassLoader$1.run(URLClassLoader.java:348)
at java.security.AccessController.doPrivileged(Native Method)
at java.net.URLClassLoader.findClass(URLClassLoader.java:347)
at java.lang.ClassLoader.loadClass(ClassLoader.java:425)
at sun.misc.Launcher$AppClassLoader.loadClass(Launcher.java:312)
at java.lang.ClassLoader.loadClass(ClassLoader.java:358)
at sun.launcher.LauncherHelper.checkAndLoadMain(LauncherHelper.java:482)
==> ERROR: A failure occurred in package().
Aborting...
:: failed to build autofirma package(s)

migrev commented on 2017-08-12 08:47

@coellobranco: Pero Marzal comment java-runtime=8 is required to install this package. Bump to 1.5-3 to reflect that.

coellobranco commented on 2017-08-12 08:15

Exception in thread "main" java.lang.UnsupportedClassVersionError: es/gob/afirma/standalone/configurator/AutoFirmaConfigurator : Unsupported major.minor version 52.0

Marzal commented on 2017-06-16 14:28

With Java 7 (java-runtime-common-2-2 jre7-openjdk-headless-7.u131_2.6.9-1 jre7-openjdk-7.u131_2.6.9-1) autofirma 1.5 fails to compile
Exception in thread "main" java.lang.UnsupportedClassVersionError: es/gob/afirma/standalone/configurator/AutoFirmaConfigurator : Unsupported major.minor version 52.0

With Java 8 (java-runtime-common-2-2 jre8-openjdk-headless-8.u131-1 jre8-openjdk-8.u131-1) this exception does not occur.

nenjordi commented on 2017-06-13 11:26

You need to also import /usr/lib/AutoFirma/AutoFirma_ROOT.cer from firefox

nenjordi commented on 2017-06-13 08:04

Missing execution of java -jar /usr/lib/AutoFirma/AutoFirmaConfigurador.jar
Otherwise the .pfx file is not generated and plugin does not work.