Package Details: aurutils 2.3.3-1

Git Clone URL: https://aur.archlinux.org/aurutils.git (read-only)
Package Base: aurutils
Description: helper tools for the arch user repository
Upstream URL: https://github.com/AladW/aurutils
Keywords: aur
Licenses: custom:ISC
Submitter: Alad
Maintainer: Alad (runical, cgirard, maximbaz)
Last Packager: Alad
Votes: 139
Popularity: 5.88
First Submitted: 2016-03-26 19:17
Last Updated: 2019-11-07 17:45

Dependencies (10)

Required by (4)

Sources (2)

Pinned Comments

Alad commented on 2017-09-07 14:29

I've enabled GPG signing for this package. If you get an "unknown key" error, import the key:

gpg --recv-keys DBE7D3DD8C81D58D0A13D0E76BC26A17B9B7018A

and run makepkg again. See the wiki for more information:

https://wiki.archlinux.org/index.php/Makepkg#Signature_checking

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

Alad commented on 2019-10-26 14:03

Fixed in 2.3.2.

bbx0 commented on 2019-10-26 09:00

==> ERROR: '-d' does not have a valid database archive extension. To "fix" the issue you may uninstall the xdelta3 dependency. In aurutils 2.3.1 the delta option gets enabled automatically for repo-add but it was removed [1] in pacman.

It might be fixed in the git version of aurutils [2] but I did not test that as removing xdelta3 worked just fine.

[1] https://git.archlinux.org/pacman.git/commit/scripts/repo-add.sh.in?id=9adb0d5b37df7ca668e23877e85431dabeea005e [2] https://github.com/AladW/aurutils/commit/2a6d1ef656e22f1ecb831d16ff6191cff8c212d9#diff-e8acc63b1e238f3255c900eed37254b8

bone commented on 2019-10-25 05:13

==> ERROR: '-d' does not have a valid database archive extension. I have the same issue. I also thought it is a problem on my side. But now that you wrote the same thing, I guess it is related to the pacman upgrade to v5.2 (or something like that)

aurifier commented on 2019-10-25 03:40

Whenever I try to aur sync ... a package, I get this failure after the package builds:

==> Finished making: aurutils 2.3.1-1 (Thu 24 Oct 2019 11:38:39 PM EDT) ==> Cleaning up... ==> ERROR: '-d' does not have a valid database archive extension.

Has something gone wrong with my aur database, perhaps?

krakenfury commented on 2019-10-16 13:48

@jogdand thank you repo-remove worked.

made a mistake and deleted my original comment, so for context i had a package that i removed that was still in my custom package database. it kept trying to upgrade whenever i used aur sync -u

used repo-add before, but didn't know about repo-remove

jogdand commented on 2019-10-16 05:50

@krakenfury, you can use repo-remove as described in this (https://github.com/AladW/aurutils/issues/305#issuecomment-367068699) issue.

Also: you might want to delete deltas. For this just add .deltas suffix in package name and repeat repo-remove

Alad commented on 2019-09-28 17:01

zsh completion works fine for me. I don't support or use third-party projects like oh-my-zsh. You do need compinit enabled - see man zshcompsys.

Ucak commented on 2019-09-28 10:55

Hey, zsh completion seems to be not working, do i have to install some other packages or plugins for oh-my-zsh?

Edit: https://aur.archlinux.org/packages/aurutils/#comment-709729 thanks, compinit worked.

cgirard commented on 2019-04-01 10:14

@krutoileshii: please check pinned comments

krutoileshii commented on 2019-03-31 01:40

Got a failure with SHA256sum on this one. It seems that it should be: 5c610fdf4f9bed7cc13d3da61f0795296314f93f71ee6a808f9518311ff999a1