Package Details: aurman 2.20.1-1

Git Clone URL: https://aur.archlinux.org/aurman.git (read-only, click to copy)
Package Base: aurman
Description: AUR helper with almost pacman syntax
Upstream URL: https://github.com/polygamma/aurman
Licenses: MIT
Submitter: polygamma
Maintainer: polygamma
Last Packager: polygamma
Votes: 198
Popularity: 1.23
First Submitted: 2018-03-20 21:31
Last Updated: 2020-07-07 19:38

Pinned Comments

polygamma commented on 2018-08-21 18:02

aurman development for public use has been stopped. i suggest migrating to yay, i am not interested in any kind of feedback, bug reports, feature requests etc. anymore.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Foxboron commented on 2018-06-21 20:00

@regeya,

This is expected and any users using the AUR should be aware of how this works. Yelling about outdated VCS packages and claiming that an Arch Dev and an AUR helper developer doesn't understand the basics is just insulting to say the least.

It is even documented in the page we expect you to read. https://wiki.archlinux.org/index.php/Arch_User_Repository#Foo_in_the_AUR_is_outdated.3B_what_should_I_do.3F

polygamma commented on 2018-06-21 19:51

@regeya - https://github.com/polygamma/aurman/issues/153#issuecomment-399194590 I even provided "proof", that the version is going to be the needed one.

Anonymous comment on 2018-06-21 19:48

And you know, had someone said, "just install the package manually or from your current aur helper, some black magic bleepery will give it the right version number upon install despite the version number being wrong in the PKGBUILD," that would have been more or less acceptable. In fact, that's what I'm saying right now. :-) No need for the open hostility or the condescending behavior; could you leave this all here so that anyone else running into the problem will know?

eschwartz commented on 2018-06-21 19:13

The goal of bootstrapping packages which require versioned dependencies, of VCS packages for which the version will only be calculated when actually running makepkg to build the package, is fundamentally incompatible with upfront dependency resolution. In order to install expac-git and aurman at the correct versions, it is necessary to first install expac-git on its own, then install aurman.

This is not a problem to be solved by AUR helpers. AUR helpers can do a lot, but they cannot completely obviate the need for human interaction.

You're a Turing-complete user -- act like it.

polygamma commented on 2018-06-21 19:00

@regeya the dependency listed in the PKGBUILD of aurman is correct. aurman needs expac-git>=8.1.g5ae006f, whereas 8.1.g5ae006f-1 is the version you get, if you build expac-git as of now, so what is your problem?

xantares commented on 2018-06-19 09:22

pkgdesc should not contain the package name

eschwartz commented on 2018-06-18 18:43

@Cavsfan, I've already explained this. This is a GnuPG issue, not an issue with aurman itself. It is erroneous to ask for GnuPG support here, please consult one of the many Arch Linux support channels, e.g. the Wiki, the BBS, #archlinux on Freenode, and ask for help fixing your GnuPG which is unable to import PGP keys. This will get you an actual solution, unlike complaining here that this one key does not work (to which the only answer is "yes it does, you're wrong").

The aurman developer does not want to know about your GnuPG issues. His GnuPG works fine, and aurman works fine too. He's not necessarily an expert in GnuPG, but it's irrelevant because if he wanted to spend time providing support for GnuPG, he'd be on those other support channels providing general support on miscellaneous topics. Whereas this is the aurman-specific location for getting support specific to aurman itself.

There's no reason to "wait until it sorts itself out" -- if your GnuPG is broken, that won't magically fix itself, and it is something you should try to get fixed... by asking for support for GnuPG, in the appropriate places to get support for GnuPG on Arch Linux. Which is not here.

polygamma commented on 2018-06-18 18:26

@Cavsfan that still does not make it an aurman PKGBUILD problem, but a problem with importing PGP keys. You can find the needed public key e.g. here: https://github.com/polygamma.gpg and you may import it manually

Cavsfan commented on 2018-06-18 18:23

@polygamma, I read, duly noted and fully understood the pinned comments. The PKGBUILD was asking for this key to be installed and it failed. I thought that you would want to know as the package cannot be updated without the key. I fully apologize for making any comments on this page. @andreyv, thanks I tried that and it did not work. I'll just wait until it sorts itself out.

eschwartz commented on 2018-06-18 17:06

Please do not ask for support for GnuPG in the comments here. Thanks.

Also please make use of markdown backticks when posting code blocks and command output. But again this is GnuPG issues, not aurman issues.