Package Details: auracle-git r366.8739929-1

Git Clone URL: https://aur.archlinux.org/auracle-git.git (read-only, click to copy)
Package Base: auracle-git
Description: A flexible client for the AUR
Upstream URL: https://github.com/falconindy/auracle.git
Keywords: aur
Licenses: MIT
Conflicts: auracle
Provides: auracle
Submitter: Foxboron
Maintainer: artafinde
Last Packager: artafinde
Votes: 93
Popularity: 3.14
First Submitted: 2017-07-02 16:40
Last Updated: 2021-02-12 08:13

Required by (10)

Sources (1)

Pinned Comments

falconindy commented on 2020-05-31 15:35

FAQ:

  • The dependencies are correct. fmt and nlohmann_json are configured as subprojects for ease of development on my end, and it's only natural to statically link C++ projects, as ABI stability with exported C++ libraries isn't a thing (compared to C).
  • If you think pod2man is missing, it's a configuration problem on your end. pod2man is part of the perl package, but in a perl-specific PATH handled by /etc/profile.d/perlbin.sh
  • I'm only able to test auracle on i686 and x86_64, so that's what I'm willing to commit to in the PKGBUILD. If you want to build this on some other architecture, use makepkg -A. The "any" architecture is reserved for packages with architecture independent files (and compiled C++ is not).

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

kevr commented on 2020-10-14 09:22

makedepends doesn't include cmake or gcc/clang and the build complains.

redfish commented on 2020-08-22 22:16

If you get this error when building for ARM aarch64:

In file included from ../subprojects/abseil-cpp-20200225.2/absl/random/internal/randen_hwaes.cc:225:
/usr/lib/gcc/aarch64-unknown-linux-gnu/9.3.0/include/arm_neon.h: In function 'Vector128 {anonymous}::AesRound(const Vector128&, const Vector128&)':
/usr/lib/gcc/aarch64-unknown-linux-gnu/9.3.0/include/arm_neon.h:12452:1: error: inlining failed in call to always_inline 'uint8x16_t vaesmcq_u8(uint8x16_t)': target specific option mismatch
12452 | vaesmcq_u8 (uint8x16_t data)

Then check that in /etc/makepkg.conf CFLAGS and CXXFLAGS have the +crypto suffix in -march flag, like -march=armv8-a+crypto (the base identifier may very depending on your hardware)

Build of abseil-cpp package works because it uses CMake which adds the correct -march flag regardless of makepkg.conf, whereas when abseil-cpp is build as a subproject within this package, it uses meson, which does not add the flag and thus fails with the above error.

csts commented on 2020-08-10 11:35

Never mind. I reinstalled Auracle using yay and everything is fine now.

csts commented on 2020-08-10 11:06

I use pacaur that uses Auracle and today I get:

auracle: error while loading shared libraries: libfmt.so.6: cannot open shared object file: No such file or directory

fmt is installed, and Auracle worked fine yesterday, any solutions?

falconindy commented on 2020-08-08 23:52

I fully appreciate you ignoring the pinned comment.

shizcow commented on 2020-08-08 23:41

I was able to successfully build this package on a clean armv7h system with no problems. This was done with makepkg -A.

Missing build dependencies: pkg-config, clang (or other C++ compiler)

a821 commented on 2020-06-20 07:46

Post the full logs, not the logs you think are relevant. Is your system up to date? Otherwise try to build in a clean chroot.

Edit: did you ever sudo pip install?

the-pete commented on 2020-06-20 03:50

Missed the log:

Log of Meson test suite run on 2020-06-19T17:28:05.858629

Inherited environment: SHELL='/bin/bash' SESSION_MANAGER='local/billie:@/tmp/.ICE-unix/1143,unix/billie:/tmp/.ICE-unix/1143' NVM_RC_VERSION='' COLORTERM='truecolor' HISTCONTROL='ignorespace' XDG_MENU_PREFIX='gnome-' HISTSIZE='10000' TEXTDOMAINDIR='/usr/share/locale' SSH_AUTH_SOCK='/home/user/.ssh/SSH-Agent-Socket' IRCNICK='the-pete' XMODIFIERS='@im=ibus' DESKTOP_SESSION='gnome' SSH_AGENT_PID='3398' EDITOR='/usr/bin/vim' PWD='/home/user/working/auracle/auracle-git/src' SOURCE_DATE_EPOCH='1592612816' XDG_SESSION_DESKTOP='gnome' LOGNAME='user' XDG_SESSION_TYPE='wayland' CXXFLAGS='-march=x86-64 -mtune=generic -O2 -pipe -fno-plt' XAUTHORITY='/run/user/1000/.mutter-Xwaylandauth.QD5EM0' TZ='UTC' GJS_DEBUG_TOPICS='JS ERROR;JS LOG' GDM_LANG='en_US.UTF-8' COMMAND_MODE='legacy' LDFLAGS='-Wl,-O1,--sort-common,--as-needed,-z,relro,-z,now' HOME='/home/user' USERNAME='user' LANG='en_US.UTF-8' XDG_CURRENT_DESKTOP='GNOME' VTE_VERSION='6003' WAYLAND_DISPLAY='wayland-0' GNOME_TERMINAL_SCREEN='/org/gnome/Terminal/screen/9db57823_42f6_4785_9b75_abbbac36bbb5' CPPFLAGS='-D_FORTIFY_SOURCE=2' INVOCATION_ID='2ce64f56dd6f48c5a060ae6c768a7c31' MANAGERPID='1094' GJS_DEBUG_OUTPUT='stderr' NVM_DIR='/home/user/.nvm' GNOME_SETUP_DISPLAY=':1' XDG_SESSION_CLASS='user' TERM='xterm-256color' USER='user' GNOME_TERMINAL_SERVICE=':1.97' DISPLAY=':0' SHLVL='2' NVM_CD_FLAGS='' PAGER='/usr/bin/less' QT_IM_MODULE='ibus' MOZ_PLUGIN_PATH='/usr/lib/mozilla/plugins' XDG_RUNTIME_DIR='/run/user/1000' JOURNAL_STREAM='9:31008' XDG_DATA_DIRS='/home/user/.local/share/flatpak/exports/share/:/var/lib/flatpak/exports/share/:/usr/local/share/:/usr/share/' CHOST='x86_64-pc-linux-gnu' PATH='/home/user/.gem/ruby/2.7.0/bin:/home/user/bin:/home/user/.local/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl' GDMSESSION='gnome' CFLAGS='-march=x86-64 -mtune=generic -O2 -pipe -fno-plt' DBUS_SESSION_BUS_ADDRESS='unix:path=/run/user/1000/bus' MAIL='/var/spool/mail/user' OLDPWD='/home/user/working/auracle/auracle-git/src/auracle' TEXTDOMAIN='pacman-scripts' _='/usr/bin/meson'

the-pete commented on 2020-06-20 03:49

s/tester -v/gtester -v/ That seems like it's not relevant here. I don't have venv installed on this box. I can attach the head of the menson log with the env, i'm not seeing other logs that are relevant. The last half of that log is attached to the previous comment.

(03:41) <billie> [/home/user/working $ which pyenv
which: no pyenv in (/home/user/.gem/ruby/2.7.0/bin:/home/user/bin:/home/user/.local/bin:/usr/local/bin:/usr/local/sbin:/usr/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl)
(03:41) <billie> [/home/user/working $ sudo updatedb && locate pyenv
(03:42) <billie> [/home/user/working $

falconindy commented on 2020-06-20 01:14

The gtest-based tests look fine based on what you've posted. The integration tests are python. My guess is you've got something going on with a virtualenv, but I have no idea without logs. The regex_search test failure looks separately suspicious since it's aborting via an exception.

No idea what 'tester' is at the end of your output.