Package Details: aura 2.0.4-1

Git Clone URL: https://aur.archlinux.org/aura.git (read-only, click to copy)
Package Base: aura
Description: A secure package manager for Arch Linux and the AUR
Upstream URL: https://github.com/fosskers/aura
Licenses: GPL-3
Conflicts: aura-bin, aura-git
Provides: aura
Submitter: fosskers
Maintainer: fosskers
Last Packager: fosskers
Votes: 155
Popularity: 0.79
First Submitted: 2012-06-13 09:49
Last Updated: 2020-02-09 07:02

Pinned Comments

fosskers commented on 2020-02-02 02:43

It is recommended that you use the aura-bin package as the official way to install Aura.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 11 ... Next › Last »

insequent commented on 2014-08-15 16:15

I also ran into:

/usr/bin/ld: cannot find -lHSreflection-1.3.2

This is probably not the best fix, but I used:

sudo ln -s /usr/lib/ghc-7.8.3/site-local/reflection-1.3.2/libHSreflection-1.3.2-ghc7.8.3.so /usr/lib/ghc-7.8.3/site-local/reflection-1.3.2/libHSreflection-1.3.2.so

fosskers commented on 2014-08-14 17:24

Do you mind trying the installation process with `[haskell-core]` activated?

test0 commented on 2014-08-14 14:09

I'm not, but there has been an interesting development today: ghc is now supposed to be '<5.0', which is of course sort of bogus. But some item within the convex hull of dependencies has changed...

fosskers commented on 2014-08-12 00:29

Hey test0! Thanks for all your patience. I'm sorry this still isn't working for you.

Are you using `[haskell-core]` for your Haskell deps? It might help.
See here: https://wiki.archlinux.org/index.php/ArchHaskell#.5Bhaskell-core.5D

test0 commented on 2014-08-11 10:56

Still happening as of today...

test0 commented on 2014-08-08 17:01

I tried again today (because who knows, maybe some dependency got updated for the newer ghc), but still no luck.

test0 commented on 2014-08-01 13:54

Unfortunately, yes. The error message remains unchanged.

fosskers commented on 2014-07-31 20:20

Still happening, test0?

test0 commented on 2014-07-30 21:02

I have no external package sources configured, and there are no haskell-* packages installed on my system. Neither is ghc, which would only be pulled in as a build dependency. However, I still cannot upgrade from aura 1.2.3.1-1, the error message is the one I posted below. So, what can I do, or what am I supposed to do?

koomi commented on 2014-07-26 20:19

I see, thanks for all the effort you put into aura!

haskell-happstack/haskell-lens is at 4.3.1-1, but build date is Thu 24 Jul 2014 10:49:15 CEST.