Package Details: audiveris 5.2.4-3

Git Clone URL: https://aur.archlinux.org/audiveris.git (read-only, click to copy)
Package Base: audiveris
Description: Music score OMR engine
Upstream URL: https://github.com/Audiveris/audiveris
Licenses: AGPL3
Submitter: raember
Maintainer: raember
Last Packager: raember
Votes: 4
Popularity: 0.000003
First Submitted: 2018-08-02 07:38
Last Updated: 2021-11-03 12:37

Dependencies (7)

Required by (0)

Sources (2)

Latest Comments

1 2 Next › Last »

raember commented on 2021-11-03 12:45

Just as a heads up: I updated the PKGBUILD to automatically use Java 11 when building Audiveris, so no more such problems can arise (hopefully).

cmsigler commented on 2021-11-02 20:22

@Munto,

Thank you! :) From archlinux-java I had:

java-11-openjdk java-17-openjdk (default) java-8-openjdk

I set java-11-openjdk as default and the build succeeded.

Clemmitt

Munto commented on 2021-10-31 02:41

@cmsigler: I had the same failure.
Set your java version to 11 (does greater work too?) with archlinux-java and your build should go fine

cmsigler commented on 2021-09-29 15:17

Hi,

Sorry to post another problem, but... audiveris won't build for me now (2021-09-29). It installed jre11-openjdk-headless, jre11-openjdk and jdk11-openjdk as required by makedepends and depends. Build error:

= = =

==> Starting build()...

Configure project : targetOS=linux-x86_64

Task :compileJava FAILED

FAILURE: Build failed with an exception.

  • What went wrong: Execution failed for task ':compileJava'.

    java.lang.ExceptionInInitializerError

  • Try: Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

  • Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.

See https://docs.gradle.org/7.2/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 3s 3 actionable tasks: 3 executed ==> ERROR: A failure occurred in build(). Aborting... error making: audiveris

= = =

HTH :)

Clemmitt Sigler

raember commented on 2021-09-23 15:02

@SpotlightKid Yeah, I forgot that that task requires git to get the latest commit from the repo, but the downloaded source obviously does not contain the .git folder neccessary for that. Which is also why I used to replace that call in the build.gradle file in earlier releases, but I forgot about it and commented it out, thinking it wasn't needed. I never got that error because on a higher folder there was always a git repo, so it always took the commit hash from that instead.

I uncommented the quickfix and also updated the PKGBUILD to support the latest 5.2.4 release.

SpotlightKid commented on 2021-09-21 10:26

Still failinghere:

==> Starting build()...
Starting a Gradle Daemon, 1 incompatible Daemon could not be reused, use --status for details

> Configure project :
targetOS=linux-x86_64

> Task :git_build FAILED
fatal: not a git repository (or any of the parent directories): .git

FAILURE: Build failed with an exception.

* What went wrong:
Execution failed for task ':git_build'.
> Process 'command 'git'' finished with non-zero exit value 128

* Try:
Run with --stacktrace option to get the stack trace. Run with --info or --debug option to get more log output. Run with --scan to get full insights.

* Get more help at https://help.gradle.org

Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

You can use '--warning-mode all' to show the individual deprecation warnings and determine if they come from your own scripts or plugins.

See https://docs.gradle.org/7.2/userguide/command_line_interface.html#sec:command_line_warnings

BUILD FAILED in 8s
1 actionable task: 1 executed
==> ERROR: A failure occurred in build().

raember commented on 2021-09-08 13:41

Sorry everyone. AUR's notification email caught the eye of the spam filter. I updated the PKGBUILD to the newest version now.

phunni commented on 2021-05-10 15:55

Fails with: Deprecated Gradle features were used in this build, making it incompatible with Gradle 8.0.

brassman5 commented on 2020-04-09 07:07

Manually installing and setting default java works. Build file needs updated.

iggyvolz commented on 2019-12-24 01:45

@sankasan: I was able to build by running archlinux-java set java-8-openjdk first