Package Details: auctex-git 1:12.1.r176.g1b6e5136-1

Git Clone URL: https://aur.archlinux.org/auctex-git.git (read-only)
Package Base: auctex-git
Description: TeX/LaTeX writing environment for Emacs - git checkout
Upstream URL: http://savannah.gnu.org/projects/auctex
Licenses: GPL3
Conflicts: auctex
Provides: auctex
Submitter: haawda
Maintainer: haawda
Last Packager: haawda
Votes: 17
Popularity: 0.50
First Submitted: 2013-04-08 21:27
Last Updated: 2019-05-05 17:35

Latest Comments

« First ‹ Previous 1 2 3 Next › Last »

haawda commented on 2011-12-13 18:32

I can reproduce your error now after some investigation of the build system of auctex. If for some reason /usr/share/emacs/site-lisp/site-start.d exists on your system, auctex's build system tries to place its files there, but ths fails because in the "make install"-step redirected to $pkgdir this subdirectory is missing.

May I ask why /usr/share/emacs/site-lisp/site-start.d exists on your system? Did you create it manually or was it created by another package? If the latter is true, you can do a "pacman -Qo /usr/share/emacs/site-lisp/site-start.d/..." where ... is the name of a file in that directory.

Anonymous comment on 2011-12-13 09:50

I get this error:

test no != no || \
/bin/install -c -m 644 auctex.el /home/lu/abs/auctex-cvs/pkg//usr/share/emacs/site-lisp/site-start.d/auctex.el
/bin/install: cannot create regular file `/home/lu/abs/auctex-cvs/pkg//usr/share/emacs/site-lisp/site-start.d/auctex.el': No such file or directory
make: *** [install-startup] Error 1
==> ERROR: A failure occurred in package().
Aborting...

and pacman -Ql auctex-cvs says:
...
auctex-cvs /usr/share/emacs/site-lisp/site-start.d/auctex.el
auctex-cvs /usr/share/emacs/site-lisp/site-start.d/preview-latex.el
...

You're sure, you don't have those file installed? If not, I wonder what configuration difference could lead to this... cvs, perhaps? (I just installed as build dep of this package)

haawda commented on 2011-12-12 20:48

mstrlu, that is really strange. For me, it works without that mkdir line, and even does not install any files to that directory.

Anonymous comment on 2011-12-12 13:27

When installing it today, I needed to add

mkdir -p $pkgdir//usr/share/emacs/site-lisp/site-start.d

in package(), just before

make DESTDIR="$pkgdir/" install

to make it work.

haawda commented on 2011-11-22 17:46

There was a blank in $pkgrel, fixed now.

matse commented on 2011-11-18 17:34

Still doesn't work here (even as rood). As I don't want to spam the comment section here I opened a thread here
https://bbs.archlinux.org/viewtopic.php?id=130443

haawda commented on 2011-11-16 17:49

Seems something is wrong with your local cvs repo. Please try to adjust permissions or remove it and run makepkg again.

matse commented on 2011-11-15 19:07

This package does not build anymore since some days, it stucks with:

cvs checkout: warning: failed to open /home/.../.cvspass for reading: No such file or directory
cvs checkout: Updating auctex
U auctex/.cvsignor

Any suggestions?

haawda commented on 2010-10-15 02:27

Another patch is no longer needed (ghostscript.9.0.0.patch).

haawda commented on 2010-09-18 14:13

I removed the patch. The ConTeXt-fix should be included automatically when committed upstream.