Package Details: atlas-lapack 3.10.3-4

Git Clone URL: https://aur.archlinux.org/atlas-lapack.git (read-only, click to copy)
Package Base: atlas-lapack
Description: Automatically Tuned Linear Algebra Software
Upstream URL: http://math-atlas.sourceforge.net/
Licenses: BSD, custom:lapack
Conflicts: atlas-lapack-base, blas, cblas, lapack, openblas, openblas-lapack
Provides: atlas-lapack-base, blas, cblas, lapack
Submitter: ilpianista
Maintainer: a.kudelin
Last Packager: a.kudelin
Votes: 93
Popularity: 0.23
First Submitted: 2008-04-24 01:36
Last Updated: 2019-11-15 18:37

Required by (315)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

Archange commented on 2015-12-27 21:53

@jose1711: I have the same issue on my laptop, on my server, on a friend laptop… And nothing I’ve tried to disable throttling worked in regard to compiling ATLAS…

jose1711 commented on 2015-12-27 21:49

Parallel make command configured as '$(MAKE) -j 2'
CPU Throttling apparently enabled!
It appears you have cpu throttling enabled, which makes timings
unreliable and an ATLAS install nonsensical. Aborting.
See ATLAS/INSTALL.txt for further information
xconfig exited with 1

giniu commented on 2015-11-14 20:23

Thanks, I will check it out.

greyltc commented on 2015-11-14 10:19

Hi giniu, could you please have a look at the recent change in atlas-lapack-base:
https://projects.archlinux.org/svntogit/community.git/commit/trunk?h=packages/atlas-lapack-base&id=3cf00de8e4fc80a2e67b1b7348b425da3d5279e4

which was made to fix:
https://bugs.archlinux.org/task/47049

and make the same change here? Thanks.

piratejon commented on 2015-10-22 00:09

I am getting a different MD5 for atlas3.10.2.tar.bz2 which is 0103b909e19ca9c6497a7ae696c16480

Archange commented on 2015-10-14 22:48

I’m having trouble w.r.t. disabling cpu throttling.

Build fails on:
CPU Throttling apparently enabled!
It appears you have cpu throttling enabled, which makes timings
unreliable and an ATLAS install nonsensical. Aborting.

I’ve set all the core to performance, force them to be at their maximum frequency, but it still fails.

epitron commented on 2015-09-10 03:15

Strange issue: when the `afl` package is installed, ATLAS tries to use `afl-gcc` instead of `gcc`.

I skimmed the configure script and the Makefile, and there doesn't seem to be anywhere it's searching for an alternative gcc executable. Passing congfigure the `--cc=gcc` option, or setting the CC environment variable to `CC=gcc` both have no effect.

The simplest solution is to remove the `afl` package when you're building ATLAS. Does anyone have a better solution?

Chais commented on 2015-05-04 18:23

This seems to be missing most of the headers. All the libs are there, but only cblas.h and clapack.h are in /usr/include.

giniu commented on 2015-04-29 12:58

Then maybe you have small amount of /tmp size on tmpfs? Most AUR helpers build in /tmp, so sometimes they get stuck when you run out of /tmp space.

mutor commented on 2015-04-29 12:54

Hey giniu,
this week I tried to install it using simple pkgbuild method, it has worked. earlier I was using AURA, that had failed couple of times.