Package Details: astroid 0.15-4

Git Clone URL: https://aur.archlinux.org/astroid.git (read-only, click to copy)
Package Base: astroid
Description: a graphical threads-with-tags style, lightweight and fast, email client for notmuch, inspired by sup and others
Upstream URL: https://github.com/astroidmail/astroid
Keywords: mail
Licenses: GPL
Submitter: gauteh
Maintainer: gauteh (jheinz)
Last Packager: jheinz
Votes: 22
Popularity: 0.008460
First Submitted: 2015-09-20 10:24
Last Updated: 2019-07-19 11:14

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 Next › Last »

grazzolini commented on 2017-05-31 18:54

@MarcinWieczorek
He doesn't need to bump anything. It is up to you to handle rebuilds. This is not how the AUR works.

MarcinWieczorek commented on 2017-05-31 16:15

The package must be rebuilt due to boost-libs update. @gauteh please bump the pkgrel.

archfroggy commented on 2017-04-30 20:41

@gauteh: Works fine for me now... Thanks!

gauteh commented on 2017-04-30 19:35

I made a small release that should fix these issues.

grazzolini commented on 2017-04-30 13:40

@gauteh

By the way, I am also hitting the same error archfroggy did. And, Arch is packaging the latest notmuch version.

grazzolini commented on 2017-04-30 13:35

@gauteh

The PKGBUILD is configuring scons to use -j 8 for parallelism. Not all machines can take this lightly (my machine froze twice until I figured this). Build options should be handled by the user themselves, either by setting on /etc/makepkg.conf or ~/.makepkg.conf or by editing the PKGBUILD themselves.

gauteh commented on 2017-04-30 10:20

You can do scons --verbose when compiling directly from the source and see if you get some more information from there.

archfroggy commented on 2017-04-30 09:44

@gauteh: Thanks for taking a look at this. I am pretty sure there shouldn't be an old notmuch version lying around:

$ pacman -Q | grep notmuch
notmuch 0.24.1-2
notmuch-runtime 0.24.1-2
notmuch-vim 0.24.1-2

AFAIK this should be the most current one in the official arch repos? Is there any other way to check which one is used by astroid? I don't find any hint in the build log whenever it fails.

gauteh commented on 2017-04-30 09:17

@archfroggy: Are you sure you're not using an old notmuch version lying around somewhere?

archfroggy commented on 2017-04-29 17:17

Hi,

fails to build with several errors warnings:

In file included from test/test_notmuch.cc:10:0:
/usr/include/notmuch.h:875:1: note: declared here
notmuch_query_search_threads (notmuch_query_t *query);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~
test/test_notmuch.cc:123:51: error: too many arguments to function 'notmuch_threads_t* notmuch_query_search_threads(notmuch_query_t*)'
st = notmuch_query_search_threads (q, &threads);
^
In file included from test/test_notmuch.cc:10:0:
/usr/include/notmuch.h:875:1: note: declared here
notmuch_query_search_threads (notmuch_query_t *query);
^~~~~~~~~~~~~~~~~~~~~~~~~~~~
test/test_notmuch.cc:123:51: error: cannot convert 'notmuch_threads_t* {aka _notmuch_threads*}' to 'notmuch_status_t {aka _notmuch_status}' in assignment
st = notmuch_query_search_threads (q, &threads);
^
scons: *** [test/test_notmuch.o] Error 1
scons: building terminated because of errors.

Installed notmuch version: notmuch 0.24.1

Any ideas?

Thanks