Package Details: asf 4.1.1.7-2

Git Clone URL: https://aur.archlinux.org/asf.git (read-only, click to copy)
Package Base: asf
Description: Steam cards farmer.
Upstream URL: https://github.com/JustArchiNET/ArchiSteamFarm
Licenses: Apache
Submitter: Gilrain
Maintainer: Gilrain
Last Packager: Gilrain
Votes: 15
Popularity: 0.008006
First Submitted: 2016-04-02 13:31
Last Updated: 2020-01-16 08:59

Dependencies (6)

Required by (1)

Sources (6)

Pinned Comments

Gilrain commented on 2020-01-15 15:42

Compiling asf (or anything really) using community dotnet is broken right now (https://bugs.archlinux.org/task/65128).

Gilrain commented on 2019-12-16 10:50

This package is now compiling the source code.

For now, you'll see these namcap warnings: W: ELF file ('usr/lib/asf/ArchiSteamFarm') lacks FULL RELRO, check LDFLAGS. W: ELF file ('usr/lib/asf/ArchiSteamFarm') lacks PIE.

I'll investigate further when community is updated to v3.x, since the benefits of those options would be lost while using dotnet AUR binaries.

Latest Comments

1 2 3 4 5 Next › Last »

Gilrain commented on 2020-01-15 15:42

Compiling asf (or anything really) using community dotnet is broken right now (https://bugs.archlinux.org/task/65128).

Gilrain commented on 2019-12-19 01:51

AFAIK it's not possible to use checksum checks on git clones.

Not sums but commits, just like the one you used for ASF-ui. They offer the same level of control since they are unique hash.

You might even be using such packages right now (https://www.archlinux.org/packages/extra/x86_64/git/). glibc and linux being the more obvious.

As for now, all the sha256 sums tell you is that the archive was not modified between the time I downloaded it and you build the package. If GitHub were publishing sums, then it would be another story…

Lucki commented on 2019-12-18 23:48

[…] by using git for the next stable release.

Not sure if the guidelines will be met when using git: "Do not diminish the security or validity of a package (e.g. by removing a checksum check […]". AFAIK it's not possible to use checksum checks on git clones.

While at it: The sources should be unique now. They overhauled the guidelines the other days.

Gilrain commented on 2019-12-18 17:54

Thank you Lucki for doing the leg work. I'll pretty it up by using git for the next stable release.

Lucki commented on 2019-12-18 12:23

@JustArchi: This package doesn't clone the git repository so the git commands aren't available. Downloading the targeting commit seems to do the same.

@Gilrain: This got me the UI back:

diff --git a/.SRCINFO b/.SRCINFO
index 5931620..bd91133 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
 pkgbase = asf
    pkgdesc = Steam cards farmer.
    pkgver = 4.1.1.4
-   pkgrel = 1
+   pkgrel = 2
    url = https://github.com/JustArchiNET/ArchiSteamFarm
    install = install
    changelog = changelog
@@ -10,16 +10,19 @@ pkgbase = asf
    arch = aarch64
    license = Apache
    makedepends = dotnet-sdk>=3.1
+   makedepends = npm
    depends = aspnet-runtime>=3.1
    backup = var/lib/asf/config/ASF.json
    backup = usr/lib/asf/NLog.config
    source = https://github.com/JustArchi/ArchiSteamFarm/archive/4.1.1.4.tar.gz
+   source = asf-ASF-ui-575e11498d432ec37a08236b8801110addac676d.tar.gz::https://github.com/JustArchiNET/ASF-ui/archive/575e11498d432ec37a08236b8801110addac676d.tar.gz
    source = asf.sh
    source = service
    source = service.user
    source = ASF.json
    source = NLog.config
    sha256sums = 7da3b7954300ef6a69e1ab97f96ccc66c03ccd36165c90a54cb3e539c5741d1b
+   sha256sums = 16283371243377d768bc3ee8d175e7bc0f291178d419cf245478516cc72e2b78
    sha256sums = 8d76996c1024b80704b25af8a8800ef3f8a8a518d19c2a1e85ba62b58b22cdfd
    sha256sums = ba1ff85e55e56d71dbdd0d898244ff7725bced8625f29c5389e28525e6cdb987
    sha256sums = b627c8d4b3ba7f194a44749bd401b33bae601b9570da98e457737a6f9cfa408f
diff --git a/PKGBUILD b/PKGBUILD
index ffea5db..6be368b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,29 +2,37 @@

 pkgname="asf"
 pkgver="4.1.1.4"
-pkgrel=1
+pkgrel=2
+_asfuicommit="575e11498d432ec37a08236b8801110addac676d"
 pkgdesc="Steam cards farmer."
 arch=('x86_64' 'armv7h' 'aarch64')
 url="https://github.com/JustArchiNET/ArchiSteamFarm"
 license=('Apache')
 depends=('aspnet-runtime>=3.1')
-makedepends=('dotnet-sdk>=3.1')
+makedepends=('dotnet-sdk>=3.1' 'npm')
 changelog=changelog
 backup=('var/lib/asf/config/ASF.json' 'usr/lib/asf/NLog.config')
 install=install
 source=("https://github.com/JustArchi/ArchiSteamFarm/archive/${pkgver}.tar.gz"
+        "${pkgname}-ASF-ui-${_asfuicommit}.tar.gz::https://github.com/JustArchiNET/ASF-ui/archive/${_asfuicommit}.tar.gz"
         "${pkgname}.sh"
         "service"
         "service.user"
         "ASF.json"
         "NLog.config")
 sha256sums=('7da3b7954300ef6a69e1ab97f96ccc66c03ccd36165c90a54cb3e539c5741d1b'
+            '16283371243377d768bc3ee8d175e7bc0f291178d419cf245478516cc72e2b78'
             '8d76996c1024b80704b25af8a8800ef3f8a8a518d19c2a1e85ba62b58b22cdfd'
             'ba1ff85e55e56d71dbdd0d898244ff7725bced8625f29c5389e28525e6cdb987'
             'b627c8d4b3ba7f194a44749bd401b33bae601b9570da98e457737a6f9cfa408f'
             'e63a92fd8008c40dab963161bdac967b57146553c00f114469c204ac6e1795b2'
             '1353977a61a2e8700df80729cabc88f453b704a0c6ccf45d80a91691fcf6338f')

+prepare() {
+    mkdir -p "ArchiSteamFarm-${pkgver}/ASF-ui"
+    cp -rdp --no-preserve=ownership "ASF-ui-${_asfuicommit}/." "ArchiSteamFarm-${pkgver}/ASF-ui"
+}
+
 build() {
     cd ArchiSteamFarm-${pkgver}
     export DOTNET_CLI_TELEMETRY_OPTOUT=1

Gilrain commented on 2019-12-18 09:32

ASF-ui will be integrated, eventually. I ran out of time trying to understand what went wrong with the v4.1.1.3 binaries and finally switching to source. As always, feel free to contribute a patch for the PKGBUILD.

JustArchi commented on 2019-12-17 21:54

@Lucki this is likely because you're either missing ASF-ui submodule in the source, missing npm to build ASF-ui with, or both. Source on GitHub sadly doesn't recurse into submodules, @Gilrain would need to add sub-step after extraction such as git submodule sync --recursive && git submodule update --init --recursive, perhaps also some git init before. In addition to that you'll need some arch package providing npm for ASF-ui to build. My cc.sh script that Gilrain is using verifies that ASF-ui source and npm command are available during build.

If you'd like/need any ASF-related thing from me to provide, best to raise issue in ASF repo directly, since third-party packaging is part of ASF development, at least to the point of providing a base to work with. For now I don't see such a thing, which is good, makes me believe that ASF source code is easy enough to compile and use, but perhaps you'd appreciate some option that isn't considered as of now.

Lucki commented on 2019-12-16 12:13

While building I get WARNING: ASF-ui dependencies are missing, skipping build of ASF-ui... and ASF-ui isn't available to me. Are you planning to include these or do you want to exclude the UI in a seperate package?

Gilrain commented on 2019-12-16 10:50

This package is now compiling the source code.

For now, you'll see these namcap warnings: W: ELF file ('usr/lib/asf/ArchiSteamFarm') lacks FULL RELRO, check LDFLAGS. W: ELF file ('usr/lib/asf/ArchiSteamFarm') lacks PIE.

I'll investigate further when community is updated to v3.x, since the benefits of those options would be lost while using dotnet AUR binaries.

Lucki commented on 2019-02-19 16:11

Fixed with 4.0.0.8.