Package Details: aseprite 1.2.25-1

Git Clone URL: https://aur.archlinux.org/aseprite.git (read-only, click to copy)
Package Base: aseprite
Description: Create animated sprites and pixel art
Upstream URL: http://www.aseprite.org/
Keywords: animation art editor gamedev image pixel sprites
Licenses: custom
Conflicts: aseprite-git, aseprite-gpl, skia-git
Submitter: benob
Maintainer: fbrennan (abueide, rouhannb)
Last Packager: rouhannb
Votes: 77
Popularity: 1.43
First Submitted: 2011-11-01 17:40
Last Updated: 2020-08-22 17:34

Required by (1)

Sources (34)

Pinned Comments

rouhannb commented on 2020-04-01 04:31

I decided to try it out for myself, and the same thing is happening to me. I’m not really sure why it’s happening, but my guess is that it has something to do with makepkg. I’ve tried building the AUR package depot-tools-git and I ran into the same problem, but cloning the repository by hand works fine.

I’ll just leave this pinned until the problem goes away: if the package is hanging when downloading depot_tools, run git clone --bare https://chromium.googlesource.com/chromium/tools/depot_tools.git depot_tools and rerun makepkg.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 ... Next › Last »

birdsnotberries commented on 2019-11-22 10:12

The hash for aseprite.desktop is outdated https://gitlab.com/snippets/1915645

rouhannb commented on 2019-08-31 14:57

I made a PKGBUILD that does what @jeancf suggested without needing a separate aseprite-skia-git package. I have a diff at https://hastebin.com/otehapasov if anyone wants to check it out

Also it looks like libwebp is statically linked so it's not needed as a dependency.

EDIT: Looks like hastebin is down...? I've posted it at https://paste.ee/p/p7uiM if so.

jeancf commented on 2019-07-10 19:04

the AUR package aseprite-git builds the aseprite dependency, compiles fine and runs. maybe this package can use the same method.

warmwaffles commented on 2019-07-03 15:19

@jusw85 the ticket that dacap is tracking for skia stuff is here https://github.com/aseprite/aseprite/issues/139 I recently added a comment about trying to get it to compile for arch

jusw85 commented on 2019-07-03 14:10

I wasn't able to build with a current version of skia, in case anyone's thinking of fixing the current skia-git to build aseprite with. Even though aseprite-skia is only six months old, there are too many backward compatibility breaking changes. Some of them can be trivially hacked around e.g. patching os/CMakeLists.txt in laf to point to new SKCMS location, adding base directory for includes, but APIs have been wholesale changed or removed

warmwaffles commented on 2019-07-03 04:00

All right I suck at making PKGBUILD files but I made a real quick and dirty aseprite-skia-git and then altered the current PKGBUILD for aseprite to use the following

    -DCMAKE_BUILD_TYPE=RelWithDebInfo \
    -DLAF_OS_BACKEND=skia \
    -DSKIA_DIR=/usr/src/aseprite-skia/ \
    -DSKIA_OUT_DIR=/usr/lib \

Here is my glorious mess https://gist.github.com/warmwaffles/4f600d764d659d9302e7da85768aa2b0

After I ran the PKGBUILD.aseprite-skia-git and added those defines, it runs fine for me.

The AUR skia-git currently fails to compile for me. Aseprite also requires some of the source code from skia as well. This dependency is a pain in the ass to build, and it won't be going away and will be required from here on out.

warmwaffles commented on 2019-07-02 22:03

I'm getting the same error as @grevius. I'm going to checkout the older version of the PKGBUILD until something is figured out. I'm sure that separate fork of skia is gonna be a pain. You could make a new package aseprite-skia and add it as a dep here. Just seems like a PITA.

jusw85 commented on 2019-07-02 19:29

@grevius I successfully compiled and built it manually. I had to use a custom skia provided by aseprite at https://github.com/aseprite/skia. The PKGBUILD provided here won't work with skia until it's updated. I'm not sure if the latest aseprite can work without skia.

grevius commented on 2019-07-02 11:12

after the update for the version 1.2.12-2 i can't open aseprite and i have the following error: Unable to create a user-interface display. Details: Unknown error Error initializing module: gui Error initializing module: gui

abueide commented on 2019-07-02 10:39

Hey sorry I pushed the update to 1.2.12 because I thought I had it working but it turns out it was an older version of aseprite. I tried a lot of things to get the new version to compile compile with skia (the new dependency that broke this package in newer versions). If there's a way to roll back to an older version until I get this figured out please tell me.