Package Details: aseprite 1.2.25-1

Git Clone URL: https://aur.archlinux.org/aseprite.git (read-only, click to copy)
Package Base: aseprite
Description: Create animated sprites and pixel art
Upstream URL: http://www.aseprite.org/
Keywords: animation art editor gamedev image pixel sprites
Licenses: custom
Conflicts: aseprite-git, aseprite-gpl, skia-git
Submitter: benob
Maintainer: fbrennan (abueide, rouhannb)
Last Packager: rouhannb
Votes: 77
Popularity: 1.44
First Submitted: 2011-11-01 17:40
Last Updated: 2020-08-22 17:34

Required by (1)

Sources (34)

Pinned Comments

rouhannb commented on 2020-04-01 04:31

I decided to try it out for myself, and the same thing is happening to me. I’m not really sure why it’s happening, but my guess is that it has something to do with makepkg. I’ve tried building the AUR package depot-tools-git and I ran into the same problem, but cloning the repository by hand works fine.

I’ll just leave this pinned until the problem goes away: if the package is hanging when downloading depot_tools, run git clone --bare https://chromium.googlesource.com/chromium/tools/depot_tools.git depot_tools and rerun makepkg.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 ... Next › Last »

rouhannb commented on 2020-04-11 15:27

I’ve added it in.

WaffleLapkin commented on 2020-04-11 09:34

The xorgproto package is missing from makedepends array. This is what currently happens when trying to install aseprite without xorgproto installed:

==> Starting build()...
Done. Made 60 targets from 43 files in 307ms
ninja: Entering directory `out/Release-x64'
[258/1593] compile ../../src/gpu/gl/glx/GrGLMakeNativeInterface_glx.cpp
FAILED: obj/src/gpu/gl/glx/gpu.GrGLMakeNativeInterface_glx.o
c++ -MD -MF obj/src/gpu/gl/glx/gpu.GrGLMakeNativeInterface_glx.o.d -DNDEBUG -DSK_R32_SHIFT=16 -DSK_GAMMA_APPLY_TO_A8 -DSKIA_IMPLEMENTATION=1 -DSK_GL -I../.. -fstrict-aliasing -fPIC -O3 -fdata-sections -ffunction-sections -Wno-unused-parameter -std=c++17 -fno-exceptions -fno-rtti -c ../../src/gpu/gl/glx/GrGLMakeNativeInterface_glx.cpp -o obj/src/gpu/gl/glx/gpu.GrGLMakeNativeInterface_glx.o
In file included from /usr/include/GL/glx.h:30,
                 from ../../src/gpu/gl/glx/GrGLMakeNativeInterface_glx.cpp:15:
/usr/include/X11/Xlib.h:44:10: fatal error: X11/X.h: No such file or directory
   44 | #include <X11/X.h>
      |          ^~~~~~~~~
compilation terminated.
[267/1593] compile ../../src/sksl/SkSLSPIRVCodeGenerator.cpp
ninja: build stopped: subcommand failed.
==> ERROR: A failure occurred in build().
    Aborting...
Error making: aseprite

rouhannb commented on 2020-04-04 02:34

Seems that the problem only occurs when running git clone --mirror as makepkg does. I tried running that on another machine (running Ubuntu) and it worked fine.

rouhannb commented on 2020-04-01 04:31

I decided to try it out for myself, and the same thing is happening to me. I’m not really sure why it’s happening, but my guess is that it has something to do with makepkg. I’ve tried building the AUR package depot-tools-git and I ran into the same problem, but cloning the repository by hand works fine.

I’ll just leave this pinned until the problem goes away: if the package is hanging when downloading depot_tools, run git clone --bare https://chromium.googlesource.com/chromium/tools/depot_tools.git depot_tools and rerun makepkg.

sramey40 commented on 2020-04-01 02:37

I'm having the same issue as Vincentca.

rouhannb commented on 2020-03-31 15:10

If you’re referring to the Git repos, shallow cloning would be hard, if not impossible, as AFAIK Git doesn’t have a way to shallow clone specific commits.

maxcahill commented on 2020-03-31 05:09

Nice to have this package but it sure does hammer your machine and data while installing! Would it be possible to get a shallow clone on the dependencies?

rouhannb commented on 2020-03-30 20:57

I’ve had that happen to me quite a few times (though only with angle2 or swiftshader). It has nothing to do with the 3/13 update; it’s happened long before. I’m not really sure why it happens, but deleting the repo and rerunning makepkg fixes the problem.

EDIT: I forgot to mention that I think I ran into the same problem while compiling skia manually when I first updated this package. I’m almost certain it’s something funky with either Git or Google’s repos, and I can’t even begin to think of a workaround.

Vincentca commented on 2020-03-30 14:14

The aur package still doesn't seem to build. I don't know if that was updated on 3/13? It keeps hanging at the last part of the log I'm pasting below.

Preparing...
Cloning aseprite build files...
Checking aseprite dependencies...
Resolving dependencies...
Checking inter-conflicts...

Building aseprite...
==> Making package: aseprite 1.2.17-2 (Mon 30 Mar 2020 09:55:21 AM EDT)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found Aseprite-v1.2.17-Source.zip
  -> Found aseprite.desktop
  -> Cloning depot_tools git repo...
Cloning into bare repository '/var/tmp/pamac-build-corey/aseprite/depot_tools'...

rouhannb commented on 2020-03-13 22:21

Also my bad. The PKGBUILD uses a custom PATH with depot_tools, and I assumed that the which command would use that PATH. It didn’t.

Building the package worked on my system because I set the PATH when building the package by hand, and for some reason, it never reverted.

And now it looks like just entering the expanded value of which gives a completely different error that never showed up before. I’m just going to restore the old hack again. Maybe I should just use the depot_tools AUR package. Or maybe not, if that’s going to open a whole new can of worms.