Package Details: asciidoctor-pdf 1.6.0-1

Git Clone URL: (read-only, click to copy)
Package Base: asciidoctor-pdf
Description: translate asciidoctor directly to pdf
Upstream URL:
Licenses: MIT
Submitter: gaelic
Maintainer: gaelic (tba)
Last Packager: tba
Votes: 5
Popularity: 0.88
First Submitted: 2019-02-19 13:13
Last Updated: 2021-05-10 11:04

Latest Comments

1 2 Next › Last »

tba commented on 2021-04-20 09:25

It's because of ruby was upgraded to 3. Please try again. I've bumped pkgrels of my packages but you'll probably need to clean build a bunch of other dependencies.

ThinkPad commented on 2021-04-19 18:03

I am getting this error when installing via yay

error: failed to commit transaction (conflicting files)
ruby-pdf-core-0.7: /usr/bin/ruby_executable_hooks exists in filesystem (owned by ruby-ttfunk-1.5)
Errors occurred, no packages were upgraded.


sudo rm /usr/bin/ruby_executable_hooks
sudo yay -S ruby-pdf-core-0.7 --asdeps
sudo yay -S asciidoctor-pdf

solved it. But now I get a new issue

ERROR:  Error installing prawn-2.2.2.gem:
    prawn-2.2.2 requires Ruby version ~> 2.1. The current ruby version is
==> ERROR: A failure occurred in package().
error making: ruby-prawn

tba commented on 2021-03-23 16:20

@lrm, it's not needed. ruby-css_parser is the replacement as the ruby-prawn-svg dependency. What package requires ruby-css_parser-1.6?

lrm commented on 2021-03-23 15:54

ruby-css_parser-1.6 doesn't exist in AUR anymore.

tba commented on 2021-01-18 08:43


What do you mean by outdated binaries? All dependencies exist and installable

$ yay -Q --provides 'ruby-ttfunk<1.6'
ruby-ttfunk-1.5 1.5.1-3
$ yay -Q --provides 'ruby-css_parser<1.7'
ruby-css_parser-1.6 1.6.0-2

xmrdo commented on 2021-01-17 16:38

Depends on outdated binaries. Can't be installed

: no results found for ruby-ttfunk<1.6 (dependency tree: asciidoctor-pdf ruby-prawn-icon ruby-prawn ruby-ttfunk) :: no results found for ruby-css_parser<1.7 (dependency tree: asciidoctor-pdf ruby-prawn-svg ruby-css_parser) :: no results found for ruby-pdf-core<0.8 (dependency tree: asciidoctor-pdf ruby-prawn-icon ruby-prawn ruby-pdf-core)

tba commented on 2020-11-26 07:44


Thanks for reporting.

The problem is that one of dependencies is broken (specifically ruby-pdf-reader: it is hardly dependent on ruby-ascii85 version 1.0.x, and ruby-ascii85 is now 1.1.0). I've built package ruby-ascii85-1.0 to satisfy the dependency.

What you can do is one of those:

  • Report to ruby-pdf-reader maintainer for him to fix dependencies (change ruby-ascii85 to ruby-ascii85<1.1).
  • Just install ruby-ascii85-1.0 explicitly.
  • (The ugliest) Fix dependency manually in /usr/lib/ruby/gems/2.7.0/specifications/pdf-reader-2.4.1.gemspec. Find line with Ascii85 and change version ~ 1.0.0 to ~ 1.0.

satcom886 commented on 2020-11-26 00:35

I just installed this and this happens when I start asciidoctor-pdf:

Traceback (most recent call last):
        16: from /usr/bin/asciidoctor-pdf:23:in `<main>'
        15: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `activate_bin_path'
        14: from /usr/lib/ruby/2.7.0/rubygems.rb:297:in `synchronize'
        13: from /usr/lib/ruby/2.7.0/rubygems.rb:298:in `block in activate_bin_path'
        12: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
        11: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
        10: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         9: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         8: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         7: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         6: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         5: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1403:in `block in activate_dependencies'
         4: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1371:in `activate'
         3: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `activate_dependencies'
         2: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1389:in `each'
         1: from /usr/lib/ruby/2.7.0/rubygems/specification.rb:1400:in `block in activate_dependencies'
/usr/lib/ruby/2.7.0/rubygems/dependency.rb:313:in `to_specs': Could not find 'Ascii85' (~> 1.0.0) - did find: [Ascii85-1.1.0] (Gem::MissingSpecVersionError)
Checked in 'GEM_PATH=/home/satcom886/.gem/ruby/2.7.0:/usr/lib/ruby/gems/2.7.0', execute `gem env` for more information

tba commented on 2020-06-04 17:51

ruby-ttfunk<1.6 is provided by ruby-ttfunk-1.5 package. You can see it in the "Dependencies" section above: ruby-ttfunk<1.6 (ruby-ttfunk-1.5) with a link. I use yay as aur helper and it can resolve dependencies fine. Don't know about other aur helpers. FWIW, the same situation is with ruby-prawn (depends on ruby-pdf-core-0.7). Unfortunately, this versions are locked in upstream. If your aur helper cannot resolve dependencies or you build manually, you can start with building ruby-css_parser-1.6, ruby-pdf-core-0.7 and ruby-ttfunk-1.5. These are all required versioned packages.

I'm quite new to the arch packaging, but I think proper implemented aur helper must resolve these dependencies. If you have better idea of how it should be done, please share.

EDIT: fix typos

christianlupus commented on 2020-06-04 17:03

At the moment this package requires ruby-ttfunk<1.6. The corresponding AUR package is only available for version at the moment of writing. This will cause problems with the dependency checking during building.