Package Details: armory-goatpig-git v0.96.5.r0.g1d02a664-2

Git Clone URL: https://aur.archlinux.org/armory-goatpig-git.git (read-only, click to copy)
Package Base: armory-goatpig-git
Description: Armory Bitcoin wallet, built from new, official github repo w/auto selection of current python2 version
Upstream URL: https://github.com/goatpig/BitcoinArmory
Licenses: AGPL3
Conflicts: armory, armory-bin, armory-git
Provides: armory
Submitter: uncle
Maintainer: uncle
Last Packager: uncle
Votes: 3
Popularity: 0.000000
First Submitted: 2016-03-27 00:25
Last Updated: 2019-01-24 02:27

Latest Comments

« First ‹ Previous 1 2

uncle commented on 2017-05-09 21:46

I added icoutils as a makedepend, thanks for letting me know.

Frans-Willem commented on 2017-05-09 17:39

icoutils dependency is still missing.

DigitalPioneer commented on 2017-05-08 01:50

Missing (build?) dep: icoutils

Edit: Oh, looks like you updated the package for the new build system, so I'm not certain if that's still true... but unless they stopped using icotool, it probably is.

s1kx commented on 2017-05-03 10:44

Armory v0.96 has introduced the use of autotools, therefore changing the build process.

Please look at https://raw.githubusercontent.com/s1kx/aur-armory-git/master/PKGBUILD to see how armory needs to be built now:

- git submodule libfcgi needs to be pulled
- PYTHON_VERSION needs to be set

Compilation:
PYTHON_VERSION=... ./autogen.sh
PYTHON_VERSION=... ./compile
make

uncle commented on 2017-03-24 05:33

thank you @md2prof! I added rsync to the depends :-)

md2prof commented on 2017-03-18 22:05

Thanks for this package! Just a note - you should add rsync to your depends. Fails without it.

uncle commented on 2016-11-21 06:28

Note about package version: because this is a git package, even if the package version appears out of date in the AUR PKGBUILD, the most recent version will still be installed, and if you run yaourt with the "--devel" flag, it will "automagically" update all your AUR git packages to the most recent versions. With git-based PKGBUILDs there is a line (or lines) in the PKGBUILD which checks the git repo for the most recent version, regardless of the version listed in the PKGBUILD. in this case that line is:
git describe --tags --long | sed -E 's/([^-]*-g)/r\1/;s/-/./g'

That being said, I have gone ahead and updated the package version in the PKGBUILD to the most recent one, since I am already here :-) thank you for using my package, and happy bitcoining!