Package Details: arduino-samd-core 1.8.6-3

Git Clone URL: https://aur.archlinux.org/arduino-samd-core.git (read-only, click to copy)
Package Base: arduino-samd-core
Description: Arduino support for SAMD21 series ARM 32 bit microcontrollers (used on Arduino M0 Pro, MKR1000, Arduino Zero etc.)
Upstream URL: https://github.com/arduino/ArduinoCore-samd
Keywords: arduino arduino-mk
Licenses: GPL
Submitter: tuna-f1sh
Maintainer: tuna-f1sh
Last Packager: tuna-f1sh
Votes: 0
Popularity: 0.000000
First Submitted: 2018-02-13 14:22
Last Updated: 2021-02-03 12:40

Latest Comments

tuna-f1sh commented on 2021-02-03 12:33

Package is designed for Arduino-mk support and thus standard Arduino folder structure. I've updated with a a symbolic link creation to /usr/share/arduino/hardware/archlinux-arduino/samd so that it works with the AUR Arduino IDE.

You can update this package or if you just use the IDE you can use the Board Manager.

vmsh0 commented on 2021-02-02 22:02

Installed this package, but the boards don't appear in the IDE. Any idea of what might be wrong?

tuna-f1sh commented on 2020-11-30 15:43

Fixed and brought packages up to date.

plushvoxel commented on 2020-11-25 20:00

yay -S arduino-samd-core
:: There are 2 providers available for arduino-samd-core:
:: Repository AUR
    1) arduino-samd-core 2) arduino-samd-core-rc

Enter a number (default=1):
:: Checking for conflicts...
:: Checking for inner conflicts...
[Aur:1]  arduino-samd-core-1.6.16-3

:: Downloaded PKGBUILD (1/1): arduino-samd-core
  1 arduino-samd-core                        (Build Files Exist)
==> Diffs to show?
==> [N]one [A]ll [Ab]ort [I]nstalled [No]tInstalled or (1 2 3, 1-3, ^4)
==>
:: (1/1) Parsing SRCINFO: arduino-samd-core
==> ERROR: makedepends is not allowed to be empty.
error downloading sources: arduino-samd-core