Package Details: ardour-git 6.3.r55.ga4b1277f85-1

Git Clone URL: https://aur.archlinux.org/ardour-git.git (read-only, click to copy)
Package Base: ardour-git
Description: A multichannel hard disk recorder and digital audio workstation (git version)
Upstream URL: https://ardour.org/
Keywords: dssi ladspa lv2 mastering midi pro-audio production recorder sequencer
Licenses: GPL2
Groups: pro-audio
Conflicts: ardour
Provides: ardour
Submitter: None
Maintainer: SpotlightKid (dvzrv)
Last Packager: SpotlightKid
Votes: 43
Popularity: 0.030936
First Submitted: 2013-03-14 23:12
Last Updated: 2020-09-19 16:32

Dependencies (94)

Required by (2)

Sources (2)

Pinned Comments

Gimmeapill commented on 2017-08-18 10:40

This package will automatically retrieve and build the latest development snapshot of Ardour from git.

It does not need to be updated on every release, so please do not flag out of date unless the build breaks.

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Gimmeapill commented on 2020-11-09 09:17

@SpotlightKid: I'm not adding much value here anymore, will let you drive ;-)

DYSEQTA commented on 2020-09-19 03:18

@SpotlightKid: Confirmed building OK again here.

SpotlightKid commented on 2020-09-18 14:01

@DYSEQTA: This was an upstream error. Seems to have been fixed by https://github.com/Ardour/ardour/commit/d90d5c37018a9b68282d6b7030c2c339969941dd

Rebuilding now...

DYSEQTA commented on 2020-09-18 02:48

Build failing while attempting to build libardour as of 2020-09-18

SpotlightKid commented on 2020-04-29 15:37

@Terence: Now I can reproduce the error. Added the prepare function as suggested. Thanks.

Terence commented on 2020-04-28 22:47

@SpotlightKid Here it is: https://gitlab.gnome.org/GNOME/gnome-themes-extra/-/blob/master/themes/Adwaita/gtk-2.0/gtkrc

from https://www.archlinux.org/packages/extra/x86_64/gnome-themes-extra/

SpotlightKid commented on 2020-04-28 21:32

@Terence: I can't reproduce this error. ardour6 start normally, even if I put gtk-color-scheme = "text_color:white" in my ~/.gtkrc-2.0 file, as specified in the bug report.

Can you post RC file, which triggers the phenomenen for you?

Terence commented on 2020-04-28 14:18

Hey can you include the prepare() function from the community repo? At least

 # unsetting gtk2 rc (FS#54389)
  sed -e '8iexport GTK2_RC_FILES=/dev/null' -i gtk2_ardour/ardour.sh.in

Otherwise I can't launch Ardour.

Gimmeapill commented on 2020-04-24 07:27

@SpotlightKid: there you go - thanks for the hand ;-)

SpotlightKid commented on 2020-04-22 16:25

@Gimmeapill: Here's the diff for an updated PKGBUILD. If you add me as a co-maintainer I'll push it.

  • Run waf with Python 3 and drop 'python2' from makedepends
  • Add 'libwebsockets' and 'cwiid' to makedepends and optdepends
diff --git a/PKGBUILD b/PKGBUILD
index d09de1e..18d527a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,15 +6,19 @@
 # Contributor: Christopher Arndt <chris at chrisarndt.de>

 pkgname=ardour-git
-pkgver=6.0.pre0.r3201.gc87bec07cd
+pkgver=6.0.rc1.r45.gfcfaa0ac49
 pkgrel=1
 pkgdesc="A multichannel hard disk recorder and digital audio workstation"
 arch=('i686' 'x86_64')
 url="http://ardour.org/"
 license=('GPL')
 groups=('pro-audio')
-depends=('alsa-lib' 'aubio' 'gtkmm' 'liblo' 'liblrdf' 'lilv' 'suil' 'rubberband' 'taglib' 'libarchive' 'python')
-makedepends=('git' 'python2' 'boost' 'cppunit' 'doxygen' 'graphviz' 'itstool' 'lv2')
+depends=('alsa-lib' 'aubio' 'gtkmm' 'libarchive' 'liblo' 'liblrdf' 'lilv'
+         'python' 'rubberband' 'suil' 'taglib')
+makedepends=('boost' 'cppunit' 'cwiid' 'doxygen' 'git' 'graphviz' 'itstool'
+             'lv2' 'libwebsockets')
+optdepends=('cwiid: Wiimote control support'
+            'libwebsockets: WebSockets control support')
 provides=('ardour')
 conflicts=('ardour')
 source=("${pkgname%-*}::git://github.com/Ardour/ardour.git"
@@ -30,7 +34,7 @@ pkgver() {
 build() {
   cd "${srcdir}/${pkgname%-*}"

-  python2 waf configure --prefix=/usr \
+  python waf configure --prefix=/usr \
                         --configdir=/etc \
                         --with-backends=jack,alsa,dummy \
                         --libjack=weak \
@@ -40,13 +44,13 @@ build() {
                         --ptformat \
                         --no-phone-home

-  python2 waf build $MAKEFLAGS
+  python waf build $MAKEFLAGS
 }

 package() {
   cd "${srcdir}/${pkgname%-*}"

-  python2 waf --destdir="${pkgdir}" install
+  python waf --destdir="${pkgdir}" install

   # Install freedesktop.org compatible application starter desktop file
   install -Dm644 "${srcdir}/ardour.desktop" \