Package Details: arbtt 0.10.2-6

Git Clone URL: https://aur.archlinux.org/arbtt.git (read-only, click to copy)
Package Base: arbtt
Description: Automatic Rule-Based Time Tracker
Upstream URL: https://hackage.haskell.org/package/arbtt
Licenses: GPL2
Conflicts: haskell-arbtt
Provides: haskell-arbtt
Submitter: PrinceMachiavell
Maintainer: PrinceMachiavell
Last Packager: PrinceMachiavell
Votes: 3
Popularity: 0.42
First Submitted: 2019-06-02 01:59
Last Updated: 2020-04-08 02:01

Dependencies (43)

Required by (0)

Sources (1)

Latest Comments

Quatro commented on 2020-05-25 22:42

Installing is currently failing with

> yay -S arbtt
==> Error: Could not find all required packages:
    haskell-aeson<=1.5 (Wanted by: arbtt)
    haskell-aeson<1.5 (Wanted by: arbtt)

chmd commented on 2020-04-26 11:30

This package does not build for me. Any idea?

==> Starting build()...

Setup.hs:26:17: error:
    Variable not in scope:
      rawSystemProgram
        :: Distribution.Verbosity.Verbosity
           -> ConfiguredProgram -> [[Char]] -> IO a0
   |
26 |                 rawSystemProgram verb configuredProg
   |                 ^^^^^^^^^^^^^^^^
==> ERROR: A failure occurred in build().
    Aborting...
Error making: arbtt

rkmax commented on 2020-04-07 14:36

cabal binary is not present anymore on ghc, to add the cabal init; rm arbtt0102.cabal; fix need to add cabal-install to make dependencies

hurufu commented on 2020-04-05 07:19

If you want to build it sooner then this package will get fixed, you may try to add: cabal init; rm arbtt0102.cabal; before runhaskell Setup configure in a build() function in PKGBUILD file.

free.wind commented on 2020-03-12 10:46

I also can confirm the same build error

hurufu commented on 2020-03-05 23:13

I can confirm the same build error

Moggele commented on 2020-02-18 19:39

Since last update the package do not compile.

Setup.hs:26:17: error: Variable not in scope: rawSystemProgram :: Distribution.Verbosity.Verbosity -> ConfiguredProgram -> [[Char]] -> IO a0 | 26 | rawSystemProgram verb configuredProg | ^^^^^^^^^^^^^^^^

rja commented on 2019-06-15 06:05

I got the following error running arbtt-capture:

arbtt-capture: error while loading shared libraries: libHSutf8-string-1.0.1.1-Geq8jdOv4Q3LkcQoEOWDVv-ghc8.6.5.so: cannot open shared object file: No such file or directory

Please move haskell-utf8-string to the depends array.