Package Details: appgate-sdp 4.3.2-1

Git Clone URL: https://aur.archlinux.org/appgate-sdp.git (read-only, click to copy)
Package Base: appgate-sdp
Description: Software Defined Perimeter - GUI client
Upstream URL: https://www.cyxtera.com/essential-defense/appgate-sdp/support
Licenses: custom
Conflicts: appgate-sdp-5, appgate-sdp-headless
Submitter: masterdisaster
Maintainer: masterdisaster (frealgagu)
Last Packager: masterdisaster
Votes: 2
Popularity: 0.000083
First Submitted: 2018-07-19 12:05
Last Updated: 2020-03-17 12:20

Latest Comments

1 2 Next › Last »

masterdisaster commented on 2020-03-17 14:41

Hi @trygveaa and @dgallant, thank you both for the information you have provided. I have updated the current package to 4.3.2 and have created a new package for Appgate 5 (appgate-sdp-5). Both include a patch which disables the test in nm.py as described in Dave's blog post.

Regarding the certificate error: I am getting a message that the endpoint certificate is not valid on Appgate 5.0, but I can work around it by editing the profile and re-approving it. I will later try if this is also the case in 5.1 for me.

Please let me know if you encounter any issues.

dgallant commented on 2020-03-17 04:15

@trygveaa Thanks. This allows the GUI to run on 4.3.2. I ran into some DNS issues, which were resolved by modifying a single line in /opt/appgate/linux/nm.py. I am using python3.8 system python and this file does not run with it.

I wrote a post here with more details: https://davegallant.github.io/blog/2020/03/16/appgate-sdp-on-arch-linux/

trygveaa commented on 2020-03-14 12:09

The reason 4.3 and newer is not working for you is that makepkg removes static libraries by default, and the newer versions require them. Adding options=(staticlibs) to the PKGBUILD makes it work.

Here is a PKGBUILD which works for 5.0. I have just changed the version number, updated the md5sum and added that options line.

# Maintainer: Pawel Mosakowski <pawel at mosakowski dot net>
pkgname=appgate-sdp
conflicts=('appgate-sdp-headless')
pkgver=5.0.3
_download_pkgver=5.0
pkgrel=1
epoch=
pkgdesc="Software Defined Perimeter - GUI client"
arch=('x86_64')
url="https://www.cyxtera.com/essential-defense/appgate-sdp/support"
license=('custom')

# dependecies calculated by namcap
depends=('gconf' 'libsecret' 'gtk3' 'python' 'nss' 'libxss' 'nodejs' 'dnsmasq')
source=("https://sdpdownloads.cyxtera.com/AppGate-SDP-${_download_pkgver}/clients/${pkgname}_${pkgver}_amd64.deb"
        "appgatedriver.service")

options=(staticlibs)

prepare() {
    tar -xf data.tar.xz
}

package() {
    cp -dpr "${srcdir}"/{etc,lib,opt,usr} "${pkgdir}"
    mv -v "$pkgdir/lib/systemd/system" "$pkgdir/usr/lib/systemd/"
    rm -vrf "$pkgdir/lib"

    cp -v "$srcdir/appgatedriver.service" "$pkgdir/usr/lib/systemd/system/appgatedriver.service"

    mkdir -vp "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/copyright" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSE.github" "$pkgdir/usr/share/licenses/appgate-sdp"
    cp -v "$pkgdir/usr/share/doc/appgate/LICENSES.chromium.html.bz2" "$pkgdir/usr/share/licenses/appgate-sdp"
}
md5sums=('1ffc310a4aea80fb8574f7d3eaa611ec'
         '002644116e20b2d79fdb36b7677ab4cf')

I tried 5.1 too, but got a certificate error in the client when trying to authenticate. Though, I'm not sure if that's an issue with my installation, or the server, as my employer recommends using 4.3 and says they consider 5.x to be unsupported (but 5.0 worked better than 4.3 for me). Note that 5.1 requires updating appgatedriver.service as well, as the service binary has been renamed to /opt/appgate/appgate-driver.

masterdisaster commented on 2019-08-27 14:32

@dgallant

Hi, I am also looking into it, for reference this is the full error I get:

error: 140 Quitting. (node:4443) UnhandledPromiseRejectionWarning: Unhandled promise rejection (rejection id: 1): Error: Cannot find module '../screen' (node:4443) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.

It appears that the issue is with node and a module called 'screen' - not my strongest suit but will continue investigating.

dgallant commented on 2019-08-11 04:28

My employer requires >= 4.3 to be installed. When pulling that .DEB, I'm getting error: 140 when loading the GUI and the application exits.

masterdisaster commented on 2019-02-10 11:10

@frealgagu Hi, I was trying to add the .asc file however looks like Cyxtera has shuffled the download links around. Example: current .deb can be downloaded from https://sdpdownloads.cyxtera.com/AppGate-SDP-4.2/clients/appgate-sdp_4.2.1_amd64.deb I have tried to download https://sdpdownloads.cyxtera.com/AppGate-SDP-4.2/clients/appgate-sdp_4.2.1_amd64.debasc and https://sdpdownloads.cyxtera.com/AppGate-SDP-4.2/clients/appgate-sdp_4.2.1_amd64.deb.asc but no luck.

frealgagu commented on 2018-12-03 20:05

@masterdisaster, could you add the .asc to sources please?

<https://sdpdownloads.cyxtera.com/files/download/AppGate-SDP>-${_download_pkgver}/clients/${pkgname}_${pkgver}_amd64.deb{,asc}

frealgagu commented on 2018-11-28 20:23

Confirming that package is working as expected. Starting appgatedriver.service is necessary to stablish the connections.

pinophyta commented on 2018-11-16 06:11

Hey masterdisaster, Thanks for the help. It was exactly that. It connected fine upon enabling + starting 'appgatedriver.service'. Cheers.

masterdisaster commented on 2018-11-15 19:02

Hi pinophyta,

So far I have had few colleagues report that it works. My best recommendation is to see if the 'appgatedriver.service' has been started properly. The appgate client and your user do not need to be able to manipulate TUN devices, it delegates to 'appgatedriver' which should be started by systemd.