Package Details: appeditor-git r65.4c7144a-1

Git Clone URL: https://aur.archlinux.org/appeditor-git.git (read-only)
Package Base: appeditor-git
Description: AppEditor allows you to edit application entries in the application menu.
Upstream URL: https://github.com/donadigo/appeditor
Licenses: GPL
Conflicts: appeditor
Provides: appeditor
Submitter: ullebe1
Maintainer: ullebe1
Last Packager: ullebe1
Votes: 3
Popularity: 0.464618
First Submitted: 2018-04-23 19:36
Last Updated: 2018-11-09 11:48

Dependencies (5)

Required by (0)

Sources (1)

Latest Comments

yochananmarqos commented on 2019-09-02 00:43

There are tags available, please see VCS package guidelines:

pkgver() {
    cd "$srcdir/${pkgname%-git}"
    printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
}
pkgver=1.1.0.r8.b7b4350

There's no need to manually install the desktop file anymore.

It's redundant to include ninja in the makedepends array, meson depends on it.

You're already using the ${pkgname%-git} variable, why it is not used in the provides / conflicts arrays?

provides=("${pkgname%-git}")
conflicts=("${pkgname%-git}")

serdarsaglam commented on 2019-06-11 19:29

Thanks a lot, it worked very well, I was able to hide unnecessary application menus.

The only app that works for Deepin users.

Klapstuhl commented on 2018-07-11 17:16

You have to change "data/com.github.donadigo.appeditor.desktop" to "data/com.github.donadigo.appeditor.desktop.in" in the last line of PKGBUILD.

TaurohtaR commented on 2018-07-05 10:25

The same for me

install: cannot stat 'data/com.github.donadigo.appeditor.desktop': No such file or directory
==> ERROR: A failure occurred in package(). Aborting... 

btd1337 commented on 2018-07-02 01:20

install: cannot stat 'data/com.github.donadigo.appeditor.desktop': No such file or directory

==> ERROR: A failure occurred in package(). Aborting...

The archive in repository is com.github.donadigo.appeditor.desktop.in