Package Details: apertium 3.4.2-1

Git Clone URL: https://aur.archlinux.org/apertium.git (read-only, click to copy)
Package Base: apertium
Description: Language-independent machine translation engine and tools to manage language data.
Upstream URL: http://apertium.org
Licenses: GPL2
Submitter: unhammer
Maintainer: unhammer
Last Packager: unhammer
Votes: 14
Popularity: 0.000001
First Submitted: 2010-02-15 09:43
Last Updated: 2017-10-10 07:15

Latest Comments

hamkido commented on 2019-11-21 14:40

There was a problem compiling. detail: In file included from stream_5_3_1_tagger.cc:21: deserialiser.h: In static member function ‘static wchar_t Apertium::Deserialiser<wchar_t>::deserialise(std::istream&)’: deserialiser.h:230:5: error: ‘unsigned’ specified with ‘typeof’ 230 | unsigned wchar_t SerialisedType_ = 0; | ^~~~~~~~ make[2]: [Makefile:1308: stream_5_3_1_tagger.lo] Error 1 make[2]: Waiting for unfinished jobs.... libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/lttoolbox-3.3 -I/usr/lib/lttoolbox-3.3/include -I/usr/include/libxml2 -D_FORTIFY_SOURCE=2 -I/usr/include/lttoolbox-3.3 -I/usr/lib/lttoolbox-3.3/include -I/usr/include/libxml2 -Wall -Wextra -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -MT stream.lo -MD -MP -MF .deps/stream.Tpo -c stream.cc -o stream.o >/dev/null 2>&1 libtool: compile: g++ -DHAVE_CONFIG_H -I. -I.. -I/usr/include/lttoolbox-3.3 -I/usr/lib/lttoolbox-3.3/include -I/usr/include/libxml2 -D_FORTIFY_SOURCE=2 -I/usr/include/lttoolbox-3.3 -I/usr/lib/lttoolbox-3.3/include -I/usr/include/libxml2 -Wall -Wextra -march=x86-64 -mtune=generic -O2 -pipe -fno-plt -MT postchunk.lo -MD -MP -MF .deps/postchunk.Tpo -c postchunk.cc -o postchunk.o >/dev/null 2>&1 make[2]: Leaving directory '/home/hamki/.cache/yay/apertium/src/apertium-3.4.2/apertium' make[1]: [Makefile:878: all] Error 2 make[1]: Leaving directory '/home/hamki/.cache/yay/apertium/src/apertium-3.4.2/apertium' make: [Makefile:479: all-recursive] Error 1 ==> ERROR: A failure occurred in build(). Aborting... Error making: apertium

unhammer commented on 2015-07-14 08:50

If you compiled a language pair with apertium pre-3.4.0, you'll have to recompile it now (with earlier apertium versions, each language pair had to be recompiled for each update to the pcre package, but after 3.4.0 this should no longer be necessary).

unhammer commented on 2012-02-17 11:13

updated to work with new pcre