Package Details: apache-netbeans 11.1-9

Git Clone URL: https://aur.archlinux.org/apache-netbeans.git (read-only)
Package Base: apache-netbeans
Description: Apache Netbeans IDE development platform
Upstream URL: https://netbeans.apache.org
Licenses: Apache
Conflicts: apache-netbeans
Provides: apache-netbeans
Submitter: Tsynique
Maintainer: Tsynique
Last Packager: Tsynique
Votes: 12
Popularity: 0.396970
First Submitted: 2018-06-19 16:56
Last Updated: 2019-09-02 11:48

Latest Comments

iamironz commented on 2019-08-24 12:15

11.1 update please

creatorx commented on 2019-08-16 10:03

kullfar, netbeans from community repo conflicts with netbeans8 package. While this package is not. So you can install both using AUR

kullfar commented on 2019-08-15 11:47

BTW, what is the difference with https://www.archlinux.org/packages/community/any/netbeans/ ?

kullfar commented on 2019-08-15 11:46

https://netbeans.apache.org/download/index.html states "Apache NetBeans 11 feature update 1 (NB 11.1) Latest version of the IDE, released on July 22, 2019."

MetaiR commented on 2019-08-05 09:04

the one who make it flaged it as out of date should know the version 11.1 is still on beta state

creatorx commented on 2019-04-09 08:22

Hi, the link https://www-eu.apache.org/dist/incubator/netbeans/incubating-netbeans/incubating-10.0/incubating-netbeans-10.0-bin.zip is not available now (404).

Can you please update package to 11.0? I'd just changed link to

https://www-eu.apache.org/dist/incubator/netbeans/incubating-netbeans/incubating-11.0/incubating-netbeans-11.0-bin.zip

and sha fingerprint and it looks like it works.

Dwight-D commented on 2019-01-07 13:43

Maybe I've missed something but this package doesn't seem to add netbeans to the path. There is a binary in /usr/share/apache-netbeans/bin/netbeans, however.

Could this be updated to automatically add it to the path so it can be run from cli/non-desktop launchers without manual intervention from users?

adfjjv commented on 2018-09-20 13:41

Apache Netbeans 9 is compatible with JDK 8. (Source: https://github.com/apache/incubator-netbeans "NetBeans also runs with JDK 8") Please change the minimum java-runtime to 8.