Package Details: aoi 3.1.0-1

Git Clone URL: https://aur.archlinux.org/aoi.git (read-only, click to copy)
Package Base: aoi
Description: A 3D modeling and rendering studio (Art of Illusion)
Upstream URL: http://www.artofillusion.org/
Licenses: GPL
Submitter: None
Maintainer: soimort
Last Packager: soimort
Votes: 41
Popularity: 0.000000
First Submitted: 2008-08-29 18:15
Last Updated: 2020-08-03 21:45

Latest Comments

1 2 Next › Last »

Tio commented on 2020-08-04 02:41

Oh ok I see...maybe it will be fixed upstream

soimort commented on 2020-08-03 23:58

The downloaded archive seems to be corrupted for libarchive:

$ bsdtar -xf ArtOfIllusion%203.1.0-Linux.zip
bsdtar: Inconsistent uncompressed size: 16607914 in central directory, 16588776 in local header
bsdtar: Error exit delayed from previous errors.

One can extract the file manually using unzip, though. I'm not sure what is the best way to fix this issue.

Tio commented on 2020-08-03 23:18

Another error now:

  -> Found aoi.sh
==> Validating source files with md5sums...
    ArtOfIllusion%203.1.0-Linux.zip ... Passed
    aoi.sh ... Passed
==> Removing existing $srcdir/ directory...
==> Extracting sources...
  -> Extracting ArtOfIllusion%203.1.0-Linux.zip with bsdtar
bsdtar: Inconsistent uncompressed size: 16607914 in central directory, 16588776 in local header
bsdtar: Error exit delayed from previous errors.
==> ERROR: Failed to extract ArtOfIllusion%203.1.0-Linux.zip
    Aborting...
Failed to build aoi

Tio commented on 2020-08-02 11:18

Error:

  -> Found aoi.sh
==> Validating source files with md5sums...
    ArtOfIllusion303-Linux.zip ... FAILED
    aoi.sh ... Passed
==> ERROR: One or more files did not pass the validity check!
Failed to build aoi

Raimar commented on 2015-06-20 12:10

namcap says: Use java-environment instead of java-runtime as dependency.

soimort commented on 2013-12-02 00:32

That's right. Updated.

goetzc commented on 2013-12-01 23:18

The last three lines in build() should be in package(), otherwise fakeroot won't work and other directory permission problems.
http://pastebin.com/PWwva9M4

Ennoia commented on 2013-07-13 06:31

+1 for a minimal launcher

aoi.desktop

[Desktop Entry]
Version=1.0
Type=Application
Name=Art Of Illusion
Comment=3D modeling and rendering studio
Exec=aoi
Icon=/usr/share/java/aoi/Icons/64x64.png
Terminal=false
StartupNotify=false
Categories=Office;Java;

Ennoia commented on 2013-07-13 06:28

+1 for a minimal launcher

aoi.desktop

[Desktop Entry]
Version=1.0
Type=Application
Name=Art Of Illution
Comment=3D modeling and rendering studio
Exec=aoi
Icon=/usr/share/java/aoi/Icons/64x64.png
Terminal=false
StartupNotify=false
Categories=Office;Java;

Anonymous comment on 2012-07-18 08:40

How about launcher?
There isn't any launcher, it needs terminal.