Package Details: antimony 0.9.2-1

Git Clone URL: https://aur.archlinux.org/antimony.git (read-only)
Package Base: antimony
Description: Graph-based 3D CSG CAD modeller
Upstream URL: http://www.mattkeeter.com/projects/antimony/3/
Licenses: MIT
Submitter: keenerd
Maintainer: keenerd
Last Packager: keenerd
Votes: 15
Popularity: 0.012845
First Submitted: 2015-05-29 15:03
Last Updated: 2017-11-24 18:16

Latest Comments

« First ‹ Previous 1 2

oberon2007 commented on 2015-10-28 16:27

Here's a patch and updated PKGBUILD for python3.5: https://github.com/oberon2007/antimony-python3.5/tree/master/antimony

oberon2007 commented on 2015-10-28 14:06

Could you kindly update the PKGBUILD to python3.5 ?

keenerd commented on 2015-05-30 13:32

Run makepkg twice as a workaround. It'll be there the second time.

nashamri commented on 2015-05-30 13:20

I'm having the same issue as tokenwizard. I can't find the binary.

tokenwizard commented on 2015-05-29 19:50

Both this package and the "antimony" package are maintained by keenerd and both refer to same upstream URL. Is there a difference in these two packages?

tokenwizard commented on 2015-05-29 18:09

I must be THICK. I managed to install just fine, but now I can't find the binary to launch the program. It's also not showing up in my cinnamon app-menu.

Is the binary called "antimony"?

keenerd commented on 2015-05-29 17:04

Fixed.

keenerd commented on 2015-05-29 16:29

Please use a paste site if you can't be bothered to filter out the relevant parts.

franciscod commented on 2015-05-29 16:26

When running it, yields an error and exits:
"Import Error: Could not find fab Python module. Antimony will now exit."

It seems to be a git related error on build()

% pacaur -S antimony
:: Package(s) antimony not found in repositories, trying AUR...
:: resolving dependencies...
:: looking for inter-conflicts...
:: antimony-0.7.9-1 is up to date -- reinstalling

AUR Packages (1): antimony-0.7.9-1

:: Proceed with installation? [Y/n]

:: Retrieving package(s)...
:: View antimony PKGBUILD? [Y/n]

:: antimony PKGBUILD viewed
[sudo] password for fd:
:: Building antimony package(s)...
==> Making package: antimony 0.7.9-1 (Fri May 29 13:24:21 ART 2015)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
-> Found 0.7.9.tar.gz
==> Validating source files with md5sums...
0.7.9.tar.gz ... Passed
==> Extracting sources...
-> Extracting 0.7.9.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
fatal: Not a git repository (or any parent up to mount point /tmp)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
Not a git repository
To compare two paths outside a working tree:
usage: git diff [--no-index] <path> <path>
fatal: Not a git repository (or any parent up to mount point /tmp)
Stopping at filesystem boundary (GIT_DISCOVERY_ACROSS_FILESYSTEM not set).
mkdir -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/qt/../py/nodes /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/qt/../py/fab /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
==> Starting check()...
==> Entering fakeroot environment...
==> Starting package()...
mkdir -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/qt/../py/nodes /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/qt/../py/fab /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/sb
install -m 755 -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/build/antimony /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/bin/
strip /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/bin/antimony
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/2D /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/3D /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/Color /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/CSG /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/Deform /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/Export /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/function /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/Iterate /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
cp -f -R /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/nodes/Transform /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/nodes/
install -m 644 -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/fab/__init__.py /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/fab/
install -m 644 -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/fab/shapes.py /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/fab/
install -m 644 -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/fab/types.py /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/fab/
install -m 644 -p /tmp/pacaurtmp-fd/antimony/src/antimony-0.7.9/py/fab/ui.py /tmp/pacaurtmp-fd/antimony/pkg/antimony/usr/share/antimony/sb/fab/
==> Tidying install...
-> Purging unwanted files...
-> Removing libtool files...
-> Removing static library files...
-> Compressing man and info pages...
-> Stripping unneeded symbols from binaries and libraries...
==> Creating package "antimony"...
-> Generating .PKGINFO file...
-> Generating .MTREE file...
-> Compressing package...
==> Leaving fakeroot environment.
==> Finished making: antimony 0.7.9-1 (Fri May 29 13:24:23 ART 2015)
==> Installing package antimony with pacman -U...
loading packages...
warning: antimony-0.7.9-1 is up to date -- reinstalling
resolving dependencies...
looking for conflicting packages...

Packages (1) antimony-0.7.9-1

Total Installed Size: 1.48 MiB
Net Upgrade Size: 1.38 MiB

:: Proceed with installation? [Y/n] Y
(1/1) checking keys in keyring [############################################################] 100%
(1/1) checking package integrity [############################################################] 100%
(1/1) loading package files [############################################################] 100%
(1/1) checking for file conflicts [############################################################] 100%
(1/1) checking available disk space [############################################################] 100%
(1/1) reinstalling antimony [############################################################] 100%