Package Details: ansible-core-git r51467.a30c55f68a-1

Git Clone URL: https://aur.archlinux.org/ansible-core-git.git (read-only, click to copy)
Package Base: ansible-core-git
Description: Radically simple IT automation platform
Upstream URL: https://github.com/ansible/ansible
Licenses: GPL3
Conflicts: ansible-base, ansible-core, python-ansible
Provides: ansible-base, ansible-core, python-ansible
Replaces: ansible-base, ansible-core, python-ansible
Submitter: aminvakil
Maintainer: aminvakil
Last Packager: aminvakil
Votes: 26
Popularity: 0.92
First Submitted: 2020-11-14 17:48
Last Updated: 2021-04-30 09:47

Dependencies (14)

Required by (6)

Sources (1)

Pinned Comments

aminvakil commented on 2021-08-28 15:06

This repository is maintained at https://github.com/aminvakil/aur.

In case anyone had any suggestions about anything, feel free to raise a PR there.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

brenix commented on 2015-12-03 04:59

Added python2-pexpect dependency, thanks jevonearth!

jevonearth commented on 2015-12-01 18:45

The new ansible expect module requires python2-pexpect to be installed.

CipherWizard commented on 2015-08-09 03:19

python2-six is a dependency of the latest version of ansible
https://github.com/ansible/ansible/issues/11141

l3u commented on 2015-05-11 08:55

@brenix / @mschewe : version string fixed. Thanks !

brenix commented on 2015-05-10 22:17

Just a suggestion, but maybe the pkgver function could be this:
printf "%s.%s.%s" "$(cat VERSION | cut -d ' ' -f1)" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"

This results in something like: 2.0.0.14080.ded6e9b

mschewe commented on 2015-04-16 15:20

It seems that the version 2.0.0 0.0.pre breaks the regex again:

==> ERROR: pkgver is not allowed to contain colons, hyphens or whitespace.
==> ERROR: pkgver() generated an invalid version: 2.0.0 0.0.pre.13855.7e1644b
==> ERROR: Makepkg was unable to build ansible-git.

l3u commented on 2015-03-20 13:52

Updated. Thanks duckunix & quixoten.

l3u commented on 2015-03-20 08:32

Took note. Thanks for the heads up. I will update PKGBUILD later today.

duckunix commented on 2015-03-20 00:54

I flagged it out of date due to @quicoten's comment. Using the updated pkgver gives me 'ansible-git 1.9.0.13514.d1641f2-1' as of today.

quixoten commented on 2014-10-20 20:43

Would you be opposed to updating the pkgver function to the one listed below? It uses data from the VERSION file in the git repository to create a more accurate version string. Using the below method, a version of '1.8.0.12410.e8f6750' is generated. The current method generates a version of '1.6.0.1989.ge8f6750', which doesn't make a lot of sense considering the package in the community repo is already at 1.7.2.

pkgver() {
cd "$pkgname"
printf "%s.%s.%s" "$(cat VERSION | sed -r 's/^[0-9]+\.[0-9]+$/&.0/')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}