Package Details: anki20-bin 2.0.52-1

Git Clone URL: https://aur.archlinux.org/anki20-bin.git (read-only)
Package Base: anki20-bin
Description: Helps you remember facts (like words/phrases in a foreign language) efficiently
Upstream URL: http://ankisrs.net/
Licenses: AGPL3
Conflicts: anki, anki20, gstreamer0.10
Provides: anki, anki20
Submitter: Runiq
Maintainer: Runiq (suawekk)
Last Packager: YamashitaRen
Votes: 39
Popularity: 0.051336
First Submitted: 2017-02-27 16:10
Last Updated: 2019-02-07 11:37

Pinned Comments

YamashitaRen commented on 2019-02-07 11:48

Please consider updating to Anki 2.1 :

Anki 2.0 was the previous stable release. No further updates are expected, as the toolkit it was built on has been discontinued. To minimize the risk of bugs and security issues, please consider upgrading to Anki 2.1.

I am hence dropping this package.

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 Next › Last »

YamashitaRen commented on 2017-06-26 20:08

1) Never had this issue, can't reproduce. Probably related to your DE and/or the anki.desktop used by it.

2) Submitted a bug report : https://anki.tenderapp.com/discussions/ankidesktop/23998-linux-compiled-package-cant-open-the-web-browser-from-anki-for-browsing-add-ons

smls commented on 2017-06-17 10:39

I'm experiencing two issues with this package:

1) Launching Anki from KRunner or the Start menu, doesn't work. It shows up for a split second in the task bar, but then disappears and the Anki windows itself never opens. On the other hand, typing "anki" in a terminal starts Anki just fine.

2) When I click "Tools > Add-ons > Browse & Install > Browse", it fails to open the web browser, and instead prints the following to the terminal from which Anki was started:

kde-open5: /opt/anki/libssl.so.1.0.0: version `OPENSSL_1.0.2' not found (required by /usr/lib/libQt5Network.so.5)
kde-open5: /opt/anki/libcrypto.so.1.0.0: version `OPENSSL_1.0.2' not found (required by /usr/lib/libQt5Network.so.5)

Runiq commented on 2017-04-29 10:34

You can't switch the UI language without icu48. Anki is stuck on English without it.

Seems like the majority favors it. I don't personally have a problem with moving it to optdepends. Will update in a few.

@shudouken: I don't think that's a problem specific to Anki, especially since it's written in (Py)Qt. Did you maybe use the Qt->GTK style?

Edit: Scratch the "switch UI language" thing, the only thing icu48 seems to do is to get rid of a library load error. I guess I'll remove it from depends/optdepends entirely -- would that be okay too?

YamashitaRen commented on 2017-04-23 15:58

Yeah +1 for moving icu48 to optdepends.
So far I haven't found any problem in running anki without it (fr_FR.utf8 locale), apart the error message when you start anki from a console.

edit :
What do you think about it Runiq ?

ion203 commented on 2017-04-21 19:13

@Runiq re: icu48:

What does anki require icu48 for? On my system, anki works fine without it so I don't see why this should be a hard dependency. Normally wouldn't care either way for a small dep like that, but it's also an aur package and I'm personally not a fan of keeping aur packages which don't do anything.

Runiq commented on 2017-04-15 12:07

@wolf: What's the problem with the icu48 dependency?
@bhrgunatha: gstreamer is not a direct dependency of this package.

@all: I'm sorry so many of you have trouble with this package. As soon as Anki supports a Qt version >=5.8, we'll be able to build it the "proper" way again, which should solve a lot of the problems mentioned in the comments.

wolf commented on 2017-04-14 13:28

consider making icu48 optional dependency? In the mean time I'm using anki20-bin-no-icu and it seems to work fine even without it (since english is good enough for me)

bhrgunatha commented on 2017-04-13 13:21

I got around the gstreamer problem by removing the dependency from the PKBUILD.
Please maintainers - remove gstreamer from the dependencies.

birnenwerfer commented on 2017-04-06 09:38

Hi @ all,

I also have the problem with gstreamer like VesterDe, can anyone tell me how to solve it?

Anki wants to uninstall gstreamer 0.10.
Any ideas?


EDIT:
I uninstalled xfce4-mixer which was depending on gstreamer 0.10 and then uninstalled all gstreamer 0.10 Packages. gsttreamer0.10 is unmaintained by Arch and makes no sense to keep it anymore.

lsrdg commented on 2017-03-27 11:39

@DeepBlue,
thanks, https://aur.archlinux.org/packages/icu48/ did the trick.