Package Details: android-x86-64-openssl 1.1.1.i-2

Git Clone URL: https://aur.archlinux.org/android-x86-64-openssl.git (read-only, click to copy)
Package Base: android-x86-64-openssl
Description: The Open Source toolkit for Secure Sockets Layer and Transport Layer Security (Android, x86-64)
Upstream URL: https://www.openssl.org
Licenses: custom:BSD
Conflicts: android-openssl-x86_64
Replaces: android-openssl-x86_64
Submitter: Martchus
Maintainer: Martchus
Last Packager: Martchus
Votes: 0
Popularity: 0.000000
First Submitted: 2019-09-09 20:52
Last Updated: 2021-02-01 09:58

Pinned Comments

Martchus commented on 2021-01-29 10:06

Latest Comments

Martchus commented on 2021-01-29 10:06

Martchus commented on 2021-01-29 10:05

Likely I'll just have to adapt. I usually only update the package on version updates. Maybe I'll find the time at the weekend. Of course you can try to come up with a patch as well.

alexbrinister commented on 2021-01-29 03:07

It seems that android-ndk > r21.d breaks this package. I'll report on that package's page.

Martchus commented on 2021-01-28 10:36

That's the latest package I've built: https://martchus.no-ip.biz/repo/arch/ownstuff/os/x86_64/android-x86-64-openssl-1.1.1.i-1-any.pkg.tar.zst

According to the contained .BUILDINFO it is still built using android-ndk-r21.d-1-x86_64. Maybe the new version of the NDK broke something.

alexbrinister commented on 2021-01-28 05:36

I am getting an error about the NDK when I build this package (and the other android-<arch>-*openssl packages as well). Build output:

makepkg --clean --syncdeps
==> Making package: android-x86-64-openssl 1.1.1.i-1 (Thu 28 Jan 2021 12:25:02 AM EST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Found openssl-1.1.1i.tar.gz
  -> Found openssl-1.1.1i.tar.gz.asc
==> Validating source files with sha256sums...
    openssl-1.1.1i.tar.gz ... Passed
    openssl-1.1.1i.tar.gz.asc ... Skipped
==> Verifying source file signatures with gpg...
    openssl-1.1.1i.tar.gz ... Passed
==> Extracting sources...
  -> Extracting openssl-1.1.1i.tar.gz with bsdtar
==> Removing existing $pkgdir/ directory...
==> Starting build()...
***** Deprecated options: no-ui
Configuring OpenSSL version 1.1.1i (0x1010109fL) for android-x86_64
Using os-specific seed configuration
$ANDROID_NDK_HOME=/opt/android-ndk is invalid at (eval 10) line 37.

I have the following android tools installed:

local/android-environment 2-3
    Script providing common environment variables and functions for Android builds.
local/android-ndk r22-2
    Android C/C++ developer kit
local/android-sdk 26.1.1-1
    Google Android SDK
local/android-sdk-build-tools r30.0.3-4
    Build-Tools for Google Android SDK (aapt, aidl, dexdump, dx, llvm-rs-cc)
local/android-sdk-platform-tools 30.0.5-1
    Platform-Tools for Google Android SDK (adb and fastboot)

Have you seen this error before?