Package Details: android-sdk-build-tools r29.0.2-1

Git Clone URL: https://aur.archlinux.org/android-sdk-build-tools.git (read-only)
Package Base: android-sdk-build-tools
Description: Build-Tools for Google Android SDK (aapt, aidl, dexdump, dx, llvm-rs-cc)
Upstream URL: https://developer.android.com/studio/releases/build-tools
Licenses: custom
Submitter: xgdgsc
Maintainer: somekool (mynacol)
Last Packager: somekool
Votes: 459
Popularity: 1.647612
First Submitted: 2013-05-16 03:44
Last Updated: 2019-10-21 02:30

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 Next › Last »

normalraw commented on 2016-08-24 13:46

There exists a version mismatch wherein the package is installed to `/opt/android-sdk/build-tools/24.0.0` as parsed from `source.properties` even though version 24.0.1 has been specified in the PKGBUILD.

As a result, uncommenting the lines responsible for setting $PATH do not work.

Thoughts?

xgdgsc commented on 2016-08-13 01:58

@kazik117 I don' t have access to an arch machine now. Would you mind me adding you to co-maintainers to change this?

kazik117 commented on 2016-08-12 20:27

There is a bug version string in source.properties file.
I added sed -i "s@24\.0\.0@24\.0\.1@g" "${srcdir}/$_android/source.properties" before copying files to destination.

xgdgsc commented on 2016-08-01 02:00

Looking for co-maintainers.

xgdgsc commented on 2016-07-06 01:49

Thanks. Changed.

sjakub commented on 2016-07-05 20:01

I am getting this warning while building with gradle:
Observed package id 'build-tools;24.0.0' in inconsistent location '/opt/android-sdk/build-tools/24' (Expected '/opt/android-sdk/build-tools/24.0.0')

It might be a good idea to use standard paths...

xgdgsc commented on 2016-04-04 01:08

Thsnks. Changed.

edh commented on 2016-04-03 09:08

Please use depends_i686 and depends_x86_64 [1] instead of checking the CARCH.

[1] https://wiki.archlinux.org/index.php/PKGBUILD#Dependencies

xgdgsc commented on 2015-09-20 12:16

There' s a package for that: https://aur.archlinux.org/packages/ncurses5-compat-libs/. May need to change a few lines as I commented there.

zman0900 commented on 2015-09-20 10:27

Some of the libs included in this are still linked to ncurses 5. Not sure if there is anything that can even be done about it since they come pre-built, but it's probably going to cause problems.


└──╼ for f in $(find /opt/android-sdk/build-tools -type f -executable); do unset OUT; OUT=$(ldd $f | grep 'ncurses.*\.so\.5'); if [ -n "$OUT" ]; then echo "====> $f"; echo -e $OUT; echo ""; fi; done
====> /opt/android-sdk/build-tools/23.0.1/lib/libclang.so
libncurses.so.5 => not found libncurses.so.5 => not found

====> /opt/android-sdk/build-tools/23.0.1/lib/libLLVM.so
libncurses.so.5 => not found

====> /opt/android-sdk/build-tools/23.0.1/lib/libbcc.so
libncurses.so.5 => not found libncurses.so.5 => not found libncurses.so.5 => not found

====> /opt/android-sdk/build-tools/23.0.1/lib/libbcinfo.so
libncurses.so.5 => not found libncurses.so.5 => not found

====> /opt/android-sdk/build-tools/23.0.1/llvm-rs-cc
libncurses.so.5 => not found libncurses.so.5 => not found libncurses.so.5 => not found

====> /opt/android-sdk/build-tools/23.0.1/bcc_compat
libncurses.so.5 => not found libncurses.so.5 => not found libncurses.so.5 => not found libncurses.so.5 => not found