Package Details: android-armv7a-eabi-qt5 5.13.0-2

Git Clone URL: https://aur.archlinux.org/android-armv7a-eabi-qt5.git (read-only)
Package Base: android-armv7a-eabi-qt5
Description: Qt 5 for Android
Upstream URL: https://www.qt.io
Licenses: GPL3, LGPL
Groups: android-qt5
Submitter: hipersayan_x
Maintainer: hipersayan_x
Last Packager: hipersayan_x
Votes: 17
Popularity: 0.025807
First Submitted: 2018-11-22 19:15
Last Updated: 2019-07-23 21:24

Dependencies (18)

Sources (3)

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 ... Next › Last »

Emeric commented on 2019-01-18 10:40

@Martchus Thanks for pointing this page, I'll follow the discussion there!

Martchus commented on 2019-01-17 14:28

@Emeric Are you already aware of https://github.com/hipersayanX/ArchPackages/issues/1 ?

Emeric commented on 2019-01-17 12:52

Any news on the androiddeployqt bug? My applications now crash with this error:

"No implementation found for boolean org.qtproject.qt5.android.QtNative.startQtAndroidPlugin"

Martchus commented on 2019-01-12 01:37

If your app freezes after resume, that's a known Qt bug: https://bugreports.qt.io/browse/QTBUG-72101

I'm just mentioning this because it might not be that obvious to figure. I can personally wait for Qt 5.12.1 but it might be worth adding the patch in general.

hipersayan_x commented on 2018-12-12 03:37

Updated to 5.12.0, the bug with androiddeployqt still persist, I think it will be much better if we report the bug to them.

@Martchus

FFmpeg has a lot of dependencies (depending on which features you require). So that might going to be some work.

Time is not a problem.

@ak-88

android-ndk >= r18.b is now enforced, you may be able to compile it now.

ak-88 commented on 2018-12-11 16:20

Qt can't find stl library. I don't no why?

ERROR: Qt requires a compliant STL library.

ERROR: C++11 <random> is required and is missing or failed to compile.

Martchus commented on 2018-12-09 18:53

I imported the patches to my Git forks for easier rebasing because one of them didn't apply to Qt 5.12.0 anymore: https://github.com/martchus/qtbase/tree/5.12.0-android, https://github.com/martchus/qtlocation/tree/5.12.0-android

I haven't tested it, though (the mingw-w64 version is still keeping my build server busy).

Right now, FFmpeg. I will be more than happy having Qt and FFmpeg.

FFmpeg has a lot of dependencies (depending on which features you require). So that might going to be some work.

hipersayan_x commented on 2018-11-27 19:10

Which additional packages do you have in mind? :-)

Right now, FFmpeg. I will be more than happy having Qt and FFmpeg.

Martchus commented on 2018-11-27 15:57

Nice. I also adapted my OpenSSL version and other packages. I like that it is now aarch64 because the ABI name was always a bit annoying to type :-)

BTW: The latest Android NDK has an interesting way of providing GCC. They just provide a wrapper script which is actually just invoking clang. And cpp isn't available at all. That required workarounds for some packages. Maybe I'll create at some point an android-build-helper package to make this at least a bit nicer.

before we have hundreds of Android packages populating the AUR

Which additional packages do you have in mind? :-)

hipersayan_x commented on 2018-11-26 19:54

And done.