Package Details: amdvlk 2019.Q3.2-1

Git Clone URL: https://aur.archlinux.org/amdvlk.git (read-only)
Package Base: amdvlk
Description: Open-source Vulkan driver for AMD Radeon™ graphics adapters
Upstream URL: https://github.com/GPUOpen-Drivers
Keywords: amd amdvlk spvgen vulkan
Licenses: MIT
Conflicts: amdvlk-bin, amdvlk-deb, amdvlk-git
Provides: vulkan-amdvlk, vulkan-driver
Submitter: lod
Maintainer: lod
Last Packager: lod
Votes: 4
Popularity: 2.850720
First Submitted: 2019-06-07 22:12
Last Updated: 2019-07-16 08:50

Pinned Comments

lod commented on 2019-07-08 13:05

The driver exposes many settings that can customize the driver's behavior and facilitate debugging. You can add/edit settings in amdPalSettings.cfg file under one of below paths, formatted with one name,value pair per line:

  • /etc/amd
  • $XDG_CONFIG_HOME
  • $HOME/.config

This file got all functions from AMDVLK github page, but only activates "cache to disk" what is recommended for gaming.

Latest Comments

1 2 3 Next › Last »

lod commented on 2019-07-08 13:05

The driver exposes many settings that can customize the driver's behavior and facilitate debugging. You can add/edit settings in amdPalSettings.cfg file under one of below paths, formatted with one name,value pair per line:

  • /etc/amd
  • $XDG_CONFIG_HOME
  • $HOME/.config

This file got all functions from AMDVLK github page, but only activates "cache to disk" what is recommended for gaming.

lod commented on 2019-07-02 20:16

All right, thanks.

Johnnynator commented on 2019-07-02 16:16

Setting -Wno-error=deprecated-copy in pal/shared/gpuopen/cmake/AMD.cmake is enough to get it compile with gcc9. https://raw.githubusercontent.com/void-linux/void-packages/00d342bb312c1766ac4c9ba10b29dbc3259e1449/srcpkgs/amdvlk/patches/deprected-copy.patch

lod commented on 2019-06-26 10:26

I got it to build by stripping the "-Werror flags". You can give it a try -> lib32-amdvlk

I haven't pushed a new version yet, but this package now also builds spvgen.so (I guess, this isn't that interesting for most people)

lod commented on 2019-06-24 18:59

I'll do it when amdvlk starts building with gcc9. We don't have "lib32-gcc8-libs" available to build it with gcc8.....

andrejjj87 commented on 2019-06-24 18:52

сделайте пожалуйста свежую сборку под 32 некоторые игры используют тока 32 разрядную версию например (worldoftanks)

lod commented on 2019-06-22 20:32

It builds from source now ("It is recommended to install 16GB RAM in your build system"), but sadly depends on gcc8... https://github.com/GPUOpen-Drivers/AMDVLK/issues/89

lod commented on 2019-06-22 01:45

Ok than, I will do this.

Ashark commented on 2019-06-22 01:14

Yes, there are tags in git. You may pick a code for latest taggeg release.

lod commented on 2019-06-22 00:54

Well building it from source would basically be amdvlk-git but picking specific commits. Would that be better?