Package Details: amdgpu-core-meta 20.45_1188099-2

Git Clone URL: https://aur.archlinux.org/amdgpu-pro-installer.git (read-only, click to copy)
Package Base: amdgpu-pro-installer
Description: Config file /etc/ld.so.conf.d/20-amdgpu.conf
Upstream URL: https://www.amd.com/en/support/kb/release-notes/rn-amdgpu-unified-linux-20-30
Licenses: MIT
Groups: Radeon_Software_for_Linux
Submitter: LEW21
Maintainer: Ashark
Last Packager: Ashark
Votes: 98
Popularity: 3.43
First Submitted: 2016-03-28 22:44
Last Updated: 2021-01-16 23:41

Pinned Comments

Ashark commented on 2019-12-09 20:52

PKGBUILD generator is located here: https://github.com/Ashark/archlinux-amdgpu-pro

AMDGPU PRO wiki page: https://wiki.archlinux.org/index.php/AMDGPU_PRO

Latest Comments

1 2 3 4 5 6 ... Next › Last »

Ashark commented on 2021-01-17 13:25

@KatStuffs Yes, I am able, and it works. I have tested with glmark2. However, the fucking DR is not launching for me.

KatStuffs commented on 2021-01-17 01:52

Has any had luck passing this driver off as an environment variable like described in the wiki?

$ LD_LIBRARY_PATH="$PACKAGEPATH/opt/amdgpu-pro/lib/x86_64-linux-gnu:${LD_LIBRARY_PATH}" LIBGL_DRIVERS_PATH="$PACKAGEPATH/usr/lib/x86_64-linux-gnu/dri/" dri_driver="amdgpu" command

Ashark commented on 2021-01-16 23:42

@Akrai thanks for adding example to the wiki. I have checked, seems like amf works ok even without opencl-amd, so I just removed that dependency.

Akrai commented on 2021-01-15 20:53

Oh you're right, vulkan-driver is already satisfied with amdvlk, no issues uninstalling it. But ffmpeg throws this error when trying to encode without it:

[h264_amf @ 0x56452d8d3d40] DLL libamfrt64.so.1 failed to open Error initializing output stream 0:0 -- Error while opening encoder for output stream #0:0 - maybe incorrect parameters such as bit_rate, rate, width or height

So yeah, i have to keep amf-amdgpu-pro i guess.

Yo should remove opencl-amdgpu-pro-icd as deps as it doesn't exist right?

Ashark commented on 2021-01-15 20:29

@Akrai amf-amdgpu-pro just contains libamfrt64.so, but I do not know for what it is. By the way, steam does not require vulkan-amdgpu-pro, it just require vulkan-driver, which could be open.

Akrai commented on 2021-01-15 20:16

Yeah, ffmpeg fails if i remove vulkan-amdgpu-pro, which also removed amdgpu-core-meta and amdgpu-pro-core-meta but those two seems irrelevant. So what does the amf-amdgpu-pro package does? I have zero idea, as I have it uninstalled right now and ffmpeg encodes just fine

Akrai commented on 2021-01-15 20:14

I was trying to encode videos through GPU a month ago and so with the very few information of AMF encoding in linux available in the internet I achieved it. I thought I had to use the amdgpu-pro package, as I thought I had to link the ICD file that the amdgpu-pro provides (in the vulkan-amdgpu-pro one, using VK_ICD_FILENAMES=/usr/share/vulkan/icd.d/amd_pro_icd64.json) as a parameter in ffmpeg.

Now that you asked I just checked and it works to encode without linking that ICD file, so... yeah. As there is no info out there to know for sure what i really need to encode using AMF, i'm not really sure but it looks like i don't need at all any amdgpu-pro packages... Also, I can't really test to encode uninstalling amdgpu-pro as steam requires vulkan-amdgpu-pro, which is the package which provides that ICD file and so maybe if i uninstalled it then ffmpeg could not use h264_amf encoder, but i cannot test it. I could force remove it, for the test...

In fact i'm gonna do it real quick just to check

Ashark commented on 2021-01-15 19:47

@Akrai thanks, I missed that. Probably yes, I do not remember what is inside for now. Maybe it should be replaced by generic icd loader dependency, if it requires opencl. I will try to figure that out a bit later. By the way, are you using AMF? If yes, could you describe it here https://wiki.archlinux.org/index.php/AMDGPU_PRO ?

Akrai commented on 2021-01-15 19:32

So opencl-amdgpu-pro-icd dependency should be removed from amf-amdgpu-pro, right?

Ashark commented on 2021-01-15 00:17

20.45_1188099-1 update. I have removed support for opencl, because it is done in opencl-amd package (to avoid twice work). The OpenGL driver does not work for some reason for me (on RX 580). Sddm just not loads (some previous versions did not worked also). Also, DR is not starting (crashes). The AMDVLK-PRO improved a bit (removed empty directory). If you know how to fix, you are welcome. P.S. I am not researching on this right now, because as I said before, DR should respect linux standards. Anyway, as it does not support mp4, it is useless. Probably will separate vulkan-pro later from this package.