Package Details: amdapp-codexl 2.6.302-2

Git Clone URL: https://aur.archlinux.org/amdapp-codexl.git (read-only, click to copy)
Package Base: amdapp-codexl
Description: AMD CodeXL is an OpenCL, Vulkan and OpenGL Debugger and Profiler, with static OpenCL kernel analyzer. It supports OpenCL 2.0
Upstream URL: http://gpuopen.com/compute-product/codexl/
Licenses: MIT
Groups: amdapp
Submitter: Vi0L0
Maintainer: Vi0L0
Last Packager: Vi0L0
Votes: 33
Popularity: 0.000099
First Submitted: 2013-02-11 21:07
Last Updated: 2018-11-12 21:58

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 Next › Last »

Vi0L0 commented on 2013-06-30 20:17

are you using normal or pxp packages?
have you installed mesa package?

is adding line:
export LIBGL_DRIVERS_PATH="/usr/lib/dri"
into /usr/bin/CodeXL just after #!/bin/sh helping?

progtologist commented on 2013-06-27 16:23

I am getting this error when trying to launch this (or the package provided by AMD). Maybe some dependency is missing! Hardware drivers and OpenCL is running fine!
libGL error: failed to load driver: swrast
libGL error: Try again with LIBGL_DEBUG=verbose for more details.
CodeXL-bin: indirect_init.c:953: __glXNewIndirectAPI: Assertion `o > 0' failed.
/opt/AMDAPP/CodeXL/CodeXL: line 41: 4134 Aborted (core dumped) /opt/AMDAPP/CodeXL/CodeXL-bin

stativ commented on 2013-06-09 09:23

I've merged my gdebugger package into your package, as CodeXL supersedes the gDEBugger. And regarding transferring the package ownership – it's completely up to you, but you seem more than competent to maintain this package and apparently you have a lot of interest in the AMD software, too.

stativ commented on 2013-05-19 11:25

Please READ THE PKGBUILD AND PREVIOUS COMMENTS! You need to download it from the AMD website yourself.

phaazon commented on 2013-05-19 08:17

Still the same issue here:

==> ERROR: gDEBugger_LNX6.2_64.tar.gz was not found in the build directory and is not a URL.

Vi0L0 commented on 2013-02-11 21:11

I was basing on stativ's gdebugger' PKGBUILD so much that i would like to give this package to him :>.
If he will accept it of course.

stativ commented on 2013-01-22 11:15

Please don't update to gdebugger 6.2.438-4 unless you already have /usr/lib64 symlink. Currently the /usr/lib64 is present in the toolchain in [testing], but you can create it yourself.

manuel commented on 2013-01-06 22:51

Ops sorry, i should RTFM :)

stativ commented on 2013-01-06 14:43

manuel: read the PKGBUILD. The source archive has to be downloaded manually.

manuel commented on 2013-01-05 12:01

This package seems to look for the wrong source:

==> ERROR: gDEBugger_LNX6.2_64.tar.gz was not found in the build directory and is not a URL.