Package Details: alacarte-xfce 3.11.91.r18.g40c8c60-3

Git Clone URL: https://aur.archlinux.org/alacarte-xfce.git (read-only, click to copy)
Package Base: alacarte-xfce
Description: Menu editor for Xfce
Upstream URL: http://www.gnome.org
Licenses: LGPL
Groups: xfce4-goodies
Conflicts: alacarte, alacarte-git, alacarte-xfce-devel
Provides: alacarte=3.11.91.r18.g40c8c60
Submitter: Barthalion
Maintainer: jamesan
Last Packager: jamesan
Votes: 60
Popularity: 0.000167
First Submitted: 2011-07-20 07:46
Last Updated: 2018-07-14 18:19

Latest Comments

« First ‹ Previous 1 2 3 4 5 6 7 8 9 10 Next › Last »

Spike29 commented on 2012-07-05 09:26

Hi, alacarte 3.5.3 is available : http://ftp.gnome.org/pub/gnome/sources/alacarte/3.5/

The bug #677343 cyberpatrol mentioned seems to be fixed.

Spike29 commented on 2012-07-05 09:26

Hi, alacarte 3.5.3 is available : http://ftp.gnome.org/pub/gnome/sources/alacarte/3.5/

The bug #677343 cyberpatrol mentioned seems to be fixed.

pezcurrel commented on 2012-06-30 15:57

Hi, on my system alacarte-xfce 0.13.4-2 installs and launches ok, but has many problems making it almost useless:
- can't create new folders (dialog window appears, I fill it, click "create", no result)
- ticking-unticking the checkbox for visibility on/off doesn't produce any change
- can't create new separators
- can't change launchers-separators order by clicking the up-down buttons
- can't drag and drop launchers to sort them or copy them in other folders

I only get errors notification when trying to create new separators...

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 293, in on_new_separator_button_clicked
self.editor.createSeparator(parent, after=after)
File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 221, in createSeparator
self.positionItem(parent, ('Separator',), before, after)
File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 553, in positionItem
index = contents.index(after) + 1
ValueError: <GMenuTreeEntry at 0x1bdacc0> is not in list

...and when trying to sort menu entries...

Traceback (most recent call last):
File "/usr/lib/python2.7/site-packages/Alacarte/MainWindow.py", line 461, in on_move_down_button_clicked
self.editor.moveItem(item, item.get_parent(), after=after)
File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 279, in moveItem
file_id = self.copyItem(item, new_parent)
File "/usr/lib/python2.7/site-packages/Alacarte/MenuEditor.py", line 258, in copyItem
util.fillKeyFile(keyfile, dict(Categories=[], Hidden=False))
File "/usr/lib/python2.7/site-packages/Alacarte/util.py", line 35, in fillKeyFile
keyfile.set_string_list(DESKTOP_GROUP, key, item)
File "/usr/lib/python2.7/site-packages/gi/types.py", line 43, in function
return info.invoke(*args, **kwargs)
TypeError: set_string_list() takes exactly 5 arguments (4 given)

...which also makes the selected entry disappear.

Previously I had 0.13.2 installed and it had no problems. I have its aur pkg saved, but it no longer installs because the patches makepkg tries to dl from patch-tracker.debian.org are no longer available.

Anonymous comment on 2012-06-24 18:15

Maybe you should try it again when gnome-menus in [extra] is updated to 3.5.2.

Barthalion commented on 2012-06-24 17:15

I tried patches posted by cyberpatrol, but even if they have anything to bug, they don't fix anything.

Anonymous comment on 2012-06-07 00:36

The bug, Spike29 mentioned, is an upstream bug. The AUR package alacarte is affected, too, I guess.

Here are the relevant bug reports:
https://bugzilla.gnome.org/show_bug.cgi?id=677343
https://bugzilla.gnome.org/show_bug.cgi?id=677344

headkase commented on 2012-06-04 19:55

I get the same error as Spike29 when running alacarte-xfce 0.13.4-2 as a normal user. If I run it as root then it launches, but, then I'm not editing my users menus obviously.

Spike29 commented on 2012-06-04 08:38

Hi, alacarte-xfce successfully built with gnome-menus dependency replacing gnome-menus2, but then it doesn't launch.
I've got the following errors : http://pastebin.com/0x20hZ0T

Spike29 commented on 2012-06-03 15:23

Yes, please add gnome-menus.
I have the following error while compiling :

"configure: error: Package requirements (libgnome-menu-3.0 >= 3.2.0.1 pygobject-3.0) were not met:

No package 'libgnome-menu-3.0' found"

Spike29 commented on 2012-06-03 14:43