Package Details: ahoviewer-git 1.6.5.127.g518c20c-2

Git Clone URL: https://aur.archlinux.org/ahoviewer-git.git (read-only, click to copy)
Package Base: ahoviewer-git
Description: A GTK2 image viewer, manga reader, and booru browser.
Upstream URL: http://github.com/ahodesuka/ahoviewer
Licenses: MIT
Provides: ahoviewer
Submitter: jkcdarunday
Maintainer: jkcdarunday
Last Packager: jkcdarunday
Votes: 8
Popularity: 0.120701
First Submitted: 2015-09-05 17:35
Last Updated: 2020-09-12 04:45

Dependencies (12)

Required by (0)

Sources (1)

Latest Comments

rvalles commented on 2020-11-11 23:41

It seems it's b0rked, and has been for a week or so.

[5/38] Compiling C++ object src/ahoviewer.p/version.cc.o
FAILED: src/ahoviewer.p/version.cc.o
ccache c++ -Isrc/ahoviewer.p -Isrc -I../ahoviewer/src -I../ahoviewer/ext/entities -I../ahoviewer/ext/date/include -I../ahoviewer/ext/json -I../ahoviewer/ext/libnsgif -I/usr/include/glibmm-2.4 -I/usr/lib/glibmm-2.4/include -I/usr/include/glib-2.0 -I/usr/lib/glib-2.0/include -I/usr/include/sigc++-2.0 -I/usr/lib/sigc++-2.0/include -I/usr/include/gtkmm-3.0 -I/usr/lib/gtkmm-3.0/include -I/usr/include/atkmm-1.6 -I/usr/include/atk-1.0 -I/usr/include/giomm-2.4 -I/usr/lib/giomm-2.4/include -I/usr/include/libmount -I/usr/include/blkid -I/usr/include/pangomm-1.4 -I/usr/lib/pangomm-1.4/include -I/usr/include/cairomm-1.0 -I/usr/lib/cairomm-1.0/include -I/usr/include/cairo -I/usr/include/pixman-1 -I/usr/include/freetype2 -I/usr/include/libpng16 -I/usr/include/harfbuzz -I/usr/include/pango-1.0 -I/usr/include/fribidi -I/usr/include/gtk-3.0 -I/usr/include/gdk-pixbuf-2.0 -I/usr/include/gio-unix-2.0 -I/usr/include/cloudproviders -I/usr/include/at-spi2-atk/2.0 -I/usr/include/dbus-1.0 -I/usr/lib/dbus-1.0/include -I/usr/include/at-spi-2.0 -I/usr/include/gtk-3.0/unix-print -I/usr/include/gdkmm-3.0 -I/usr/lib/gdkmm-3.0/include -I/usr/include/libxml2 -I/usr/include/gstreamer-1.0 -I/usr/include/orc-0.4 -I/usr/include/libsecret-1 -flto -fdiagnostics-color=always -pipe -D_FILE_OFFSET_BITS=64 -Wall -Winvalid-pch -Wnon-virtual-dtor -std=c++17 -march=znver1 -Os -fno-plt -D_FORTIFY_SOURCE=2 -fPIE -pthread -DHAS_REMOTE_API=1 -DHAS_UNCAUGHT_EXCEPTIONS=1 -MD -MQ src/ahoviewer.p/version.cc.o -MF src/ahoviewer.p/version.cc.o.d -o src/ahoviewer.p/version.cc.o -c ../ahoviewer/src/version.cc
../ahoviewer/src/version.cc:1:10: fatal error: version.h: No such file or directory
    1 | #include "version.h"
    |          ^~~~~~~~~~~
compilation terminated.

jkcdarunday commented on 2020-09-12 04:38

Thanks for the link cobaltspace. I'll check it out the meson guidelines.

Thanks for the update too cryzed.

cobaltspace commented on 2020-09-12 03:27

It looks like you aren't that familiar with using meson. I recommend checking out https://wiki.archlinux.org/index.php/Meson_package_guidelines

For reference, this is the template from the wiki:

build() {
  arch-meson $pkgname-$pkgver build
  meson compile -C build
}

check() {
  meson test -C build
}

package() {
  DESTDIR="$pkgdir" meson install -C build
}

cryzed commented on 2020-09-03 23:39

The PKGBUILD is broken currently:

$ makepkg -fsic
==> Making package: ahoviewer-git 1.6.5.123.g7d933fd-1 (Fr 04 Sep 2020 01:38:21 CEST)
==> Checking runtime dependencies...
==> Checking buildtime dependencies...
==> Retrieving sources...
  -> Updating ahoviewer git repo...
Fetching origin
remote: Enumerating objects: 9, done.
remote: Counting objects: 100% (9/9), done.
remote: Compressing objects: 100% (1/1), done.
remote: Total 5 (delta 4), reused 5 (delta 4), pack-reused 0
Unpacking objects: 100% (5/5), 1.18 KiB | 241.00 KiB/s, done.
From git://github.com/ahodesuka/ahoviewer
   7d933fd..d566d70  master     -> master
==> Validating source files with md5sums...
    ahoviewer ... Skipped
==> Extracting sources...
  -> Creating working copy of ahoviewer git repo...
From /home/user/.cache/aurman/ahoviewer-git/ahoviewer
   7d933fd..d566d70  master     -> origin/master
Reset branch 'makepkg'
==> Starting pkgver()...
==> Updated version: ahoviewer-git 1.6.5.124.gd566d70-1
==> Removing existing $pkgdir/ directory...
==> Starting build()...
/home/user/.cache/aurman/ahoviewer-git/PKGBUILD: line 23: ./bootstrap: No such file or directory
==> ERROR: A failure occurred in build().
    Aborting...

cryzed commented on 2017-01-14 15:31

libconfig still needs to be added as a dependency, I'll flag this now out of date because you haven't reacted in over a year, and I assume this must have changed during its development cycle.

Tuerai commented on 2016-09-12 09:22

Currently ahoviewer won't launch once you update libunrar to 5.4.5 (current version in extra/libunrar). Making a symlink that points libunrar.so.5.3.11 to libunrar.so.5.4.5 seems to be a workaround for now. Not sure if rebuilding would fix it, or if it specifically looks for libunrar 5.3.11

Azul commented on 2015-12-05 08:26

you should add libconfig as one of the dependencies, will not build without it.