Package Details: adwaita-qt4 1.1.1-1

Git Clone URL: https://aur.archlinux.org/adwaita-qt4.git (read-only, click to copy)
Package Base: adwaita-qt4
Description: A style to bend Qt applications to look like they belong into GNOME Shell
Upstream URL: https://github.com/FedoraQt/adwaita-qt
Licenses: GPL
Submitter: major
Maintainer: iyanmv
Last Packager: iyanmv
Votes: 3
Popularity: 0.85
First Submitted: 2019-06-07 14:30
Last Updated: 2019-11-20 08:38

Dependencies (4)

Required by (0)

Sources (1)

Latest Comments

iyanmv commented on 2019-10-28 07:09

@plaxx @major hope now is good. Sorry for the confusion :S

major commented on 2019-10-23 16:36

Hello plaxx!

I agree with you. There is nothing but a minor confusion in the provides list. Let me clarify, adwaita-qt by default installs/provides adwaita-qt5 version. In order to install the qt4 version, one must install the adwaita-qt4 package. adwaita-qt4 package should provide adwaita-qt4 and not adwaita-qt.

Other than that, the adwaita-qt and the adwaita-qt4 packages conflict each other, and hence you cannot install them together (you would have to remove one before you install the other).

plaxx commented on 2019-10-23 16:14

Updating adwaita-qt4 forced me to remove adwaita-qt5. Trying to install adwaita-qt back (the new name without the 5) wants me to remove adwaita-qt4.

I think there is still something wrong in the adwaita-qt4 package definition since it conflicts with this version.

Anonymous comment on 2019-10-16 03:30

@iyanmv: could you please remove adwaita-qt-git from Replaces list. they are nothing to do with each other.

major commented on 2019-09-08 14:53

Hello @xcffl. I agree with you, and the package is also not updated to the latest version. Last month, I had sent a mail stating that I will be moving to another distro, and hence had changed the ownership of many packages I used to maintain. However, no one opted to take care of adwaita-qt4, and hence it has stayed like this since then. I had planned to orphan rest of the packages soon but forgot to do that.

I am really sorry, but I would not be able to continue development for Arch packages (as I don't use Arch anymore). I will ping the maintainer for adwaita-qt to have a look here (if he/she can). I really hope I will be able to come back to using Arch soon.

xcffl commented on 2019-09-08 00:53

The archive file is extracted to adwaita-qt-1.0 instead of adwaita-qt4-1.0