Package Details: advcp 8.32-4

Git Clone URL: https://aur.archlinux.org/advcp.git (read-only, click to copy)
Package Base: advcp
Description: 'cp' and 'mv' utilities with progress bar patches
Upstream URL: https://www.gnu.org/software/coreutils/
Licenses: GPL3
Provides: acp, advcp, advmv, amv, cpg, mvg
Submitter: Nrm
Maintainer: maximbaz
Last Packager: maximbaz
Votes: 39
Popularity: 1.19
First Submitted: 2012-12-03 16:51
Last Updated: 2020-12-26 16:32

Latest Comments

« First ‹ Previous 1 2 3 4 5 Next › Last »

porcaror commented on 2020-11-01 12:51

After using makepkg (the same with yay) I have the following errors:

==> Validating source files with sha256sums... coreutils-8.32.tar.xz ... Passed coreutils-8.32.tar.xz.sig ... Skipped advcpmv-0.8-8.32.patch ... Passed ==> Verifying source file signatures with gpg... coreutils-8.32.tar.xz ... FAILED (unknown public key DF6FD971306037D9) ==> ERROR: One or more PGP signatures could not be verified!

Can you help me, please?

simona commented on 2020-11-01 10:44

==> Validazione di source file con sha256sums... coreutils-8.32.tar.xz ... Verificato coreutils-8.32.tar.xz.sig ... Ignorato advcpmv-0.8-8.32.patch ... NON RIUSCITO ==> ERRORE: Uno o più file non hanno superato il controllo di validità!

simona commented on 2020-11-01 10:39

a way to have advcp and advmv as advcp and advmv and to a nice alias cp="advcp"; alias mv="advmv" into .bashrc?

b14ckr41n commented on 2018-08-19 00:26

Oky, here is the error. #error "Please port gnulib freadseek.c to your platform! Look at the definition of getc, getc_unlocked on your system, then report this to bug-gnulib." Anything you could do. Thanks again guys.

b14ckr41n commented on 2018-08-16 13:26

Could someone please update this. It was failing to build, which I cannot post now because it will not even download coreutils.If I can get coreutils downloaded I will post the error.I love this package and am VERY greatful for all you guys do. thanks

OdinEidolon commented on 2018-02-03 09:09

coreutils-8.25.tar.xz ... FAILED (unknown public key DF6FD971306037D9)

==> ERROR: One or more PGP signatures could not be verified!

timofonic commented on 2017-11-21 19:01

I made a preliminary patch for 8.26. Let's see if someone reviews it. IM A TOTAL PROGRAMMING NOOB, YOU ARE WARNED. If it's okay, I might continue with the ongoing versions.

https://0x0.st/s-tJ.patch aka advcpmv-0.8-8.26.patch (de facto canonical naming scheme)



What about making a coreutils package with this plus Gentoo patches? It would be amazing! Please...
https://dev.gentoo.org/~whissi/dist/coreutils/coreutils-8.28-patches-1.1.tar.xz

Another alternative is to use progress...
https://github.com/Xfennec/progress

Or rsync...

Or cpv, a script srapper that uses pv (pipe viewer) for that:
https://github.com/nachoparker/cpv

There's an early WIP patch that may provide a somewhat similar functionality and seems very interesting too.
https://www.reddit.com/r/linux/comments/7deo1r/ctrlt_status_key_patches_for_gentoo_for_those_who/

boscowitch commented on 2016-08-25 23:34

I adopted the patch to the new version if anyone cares:
https://github.com/boscowitch/advcpmv/tree/patch-1
also created a pull request to the original creator of the last version https://github.com/atdt/advcpmv

punk0x29a commented on 2015-07-06 11:51

gpg --keyserver keys.gnupg.net --recv-keys DF6FD971306037D9

bezirg commented on 2015-05-02 21:44

confirmed