Package Details: adsuck 2.5.0-5

Git Clone URL: https://aur.archlinux.org/adsuck.git (read-only, click to copy)
Package Base: adsuck
Description: DNS filter
Upstream URL: https://github.com/conformal/adsuck
Licenses: BSD
Submitter: acoolon
Maintainer: None
Last Packager: TheGoliath
Votes: 13
Popularity: 0.000000
First Submitted: 2010-12-17 10:03
Last Updated: 2020-01-21 19:32

Latest Comments

« First ‹ Previous 1 2 3

Anonymous comment on 2012-11-16 21:15

i was not sure how to install, but adsuck was writing over /etc/resolv.conf but was not keeping the original one.
so i added the following to the adsuck.service:
ExecStartPre=/bin/sh -c "cp /etc/resolv.conf /var/adsuck/resolv.conf"

skanky commented on 2012-10-04 09:43

Thanks for the update.

Here's what I have as my systemd service file:

----------------------------------
[Unit]
Description=Adsuck daemon
After=network.target

[Service]
Type=forking
ExecStart=/usr/sbin/adsuck -c /var/adsuck -f /resolv.conf /hosts -r /filter
ExecStop=/bin/kill $MAINPID
ExecReload=/bin/kill -HUP $MAINPID ; /bin/kill -USR1 $MAINPID

[Install]
WantedBy=multi-user.target
----------------------------------

Might need tweaking, it's based on the rc.d file and seems to run okay on my machine.
It needs to be placed at /usr/lib/systemd/system/adsuck.service.

On a slightly different note, is it possible to have filter not overwrite the current file? Make it a pacnew file, say?

jorge_barroso commented on 2012-10-03 19:34

sorry jakobcreutzfeldt, I don't know what are you talking about :$ I'll do it if you explain me what are you talking about. By now the package is already updated ^.^

jakobcreutzfeldt commented on 2012-10-03 15:54

2.4.3 is out. Also, it would be great if systemd service files were included!

joni commented on 2011-05-09 11:25

I have modified 50-adsuck-update to check if adsuck is running before replacing /etc/resolv.conf:
https://gist.github.com/962177

acoolon commented on 2011-05-08 08:17

Please update or free this package..

mimas commented on 2011-02-22 02:01

Hello, libevent is a new dependency since version 2.0.