Package Details: adom-noteye 3.3.3-6

Git Clone URL: https://aur.archlinux.org/adom-noteye.git (read-only, click to copy)
Package Base: adom-noteye
Description: A roguelike game with a quest-centric, plot driven structure (+ GUI) - Please consider buying the game on Steam
Upstream URL: http://www.adom.de/
Keywords: game roguelike
Licenses: custom:adom
Conflicts: adom, adom-restricted
Provides: adom
Submitter: eldios
Maintainer: eldios
Last Packager: eldios
Votes: 3
Popularity: 0.199271
First Submitted: 2017-11-30 15:20
Last Updated: 2019-11-29 01:49

Latest Comments

1 2 Next › Last »

mrzeznicki commented on 2019-11-29 14:25

Wow, that was fast! Thanks a lot!

eldios commented on 2019-11-29 01:33

fixed. Uploading soon.

mrzeznicki commented on 2019-11-28 23:58

Also, I noticed there is a bug in the PKGBUILD. It should be: cp -R "${srcdir}/opt/adom" "${pkgdir}/opt/" instead of cp -R "${srcdir}/adom" "${pkgdir}/opt/"

mrzeznicki commented on 2019-11-28 23:41

Hey, first of all - thanks for maintainig the package! Does it make sense to conflict with itself? This leads to funny errors when trying to install:

:: resolving dependencies...

:: unresolvable package conflicts detected

:: failed to prepare transaction (conflicting dependencies: adom-noteye)

itaton commented on 2019-08-16 08:49

Thanks for the quick fix of the pkgrel, unfortunately the build now fails for me.

cp: cannot stat '~/.cache/yay/adom-noteye/src/adom': No such file or directory

itaton commented on 2019-08-06 16:00

The pkgrel in the .SRCINFO (2) differs from the PKGBUILD (3) leading to the error message from yay "adom-noteye: local (3.3.3-3) is newer than AUR (3.3.3-2)"

btimofeev commented on 2018-03-01 17:24

Please, add to dependences list: libmad, fluidsynth, libpng12. The game does not start without these libraries.

TrialnError commented on 2018-02-07 21:41

Thanks, but not necessary ;)

Interesting that it allowed to push. Maybe possible since it was marked as inactive/deleted.

Anyway. I just wanted to make sure the guidelines are adhered and clear some questions I had. Everything achieved :)

eldios commented on 2018-02-07 19:45

Gotcha, well I can add you in there, if you want but I didn't know about your or the other contributor cause I didn't start from the aurweb repo, so I didn't have all the history.

I'm mostly maintaining this as I use it myself to keep it installed on all my PCs, so thus the motivation to adopt it, but I'm glad it's useful to somebody else :)

TrialnError commented on 2018-02-07 19:37

Well thank you for maintaining this, after free public releases were made available again. I doubt it would happen, so I had it removed from aurweb last year.

Ah, I see. The thing is with aurweb and the AUR. If packages get deleted from the aurweb, their history is still kept. See, this is the change[0] you introduced to the last existing PKGBUILD. And in this history it looks like a deliberate move, so therefor my comment.

Not sure I can follow your argument regarding avoiding repackaging. You need to repackage everytime if upstream releases a new package. And no need for pkgrel to increase because something changed in the Arch repos. Just some rm commands in prepare to use system libs (Arch way). But well. At least it is working.

<hr>

[0] https://aur.archlinux.org/cgit/aur.git/commit/?h=adom-noteye&id=8aff1c603817

Edit: Well.. the aurweb markdown parser is kinda faulty...

<https://aur.archlinux.org/cgit/aur.git/commit/?h=adom-noteye&id=[`8aff1c603817`](https://aur.archlinux.org/cgit/aur.git/commit/?h=adom-noteye&id=8aff1c603817)>

See "View changes" for the history