Package Details: actiona 3.10.0-3

Git Clone URL: https://aur.archlinux.org/actiona.git (read-only, click to copy)
Package Base: actiona
Description: A task automation tool that allows you to create and execute action lists
Upstream URL: https://wiki.actiona.tools
Licenses: GPL3
Submitter: None
Maintainer: meanjollies
Last Packager: meanjollies
Votes: 8
Popularity: 0.006260
First Submitted: 2016-05-11 20:02
Last Updated: 2019-12-23 14:39

Latest Comments

yigitdnz commented on 2019-12-23 15:27

@meanjollies Thank you. It works now.

meanjollies commented on 2019-12-23 14:40

@yigitdnz try now. It looks like the QKeyEvent header now has to be included explicitly. I'll raise an issue upstream, but I've included the fix in my patch.

yigitdnz commented on 2019-12-23 11:32

Hi. Actiona stopped working today. I tried to reinstall and got this error multiple times during build:

"error: invalid use of incomplete type ‘class QKeyEvent"

and then;

"==> ERROR: A failure occurred in build()."

meanjollies commented on 2019-04-25 14:04

@nipsky in the PKGBUILD, if you change the the patch command to patch -p0 -i ./${pkgname}.patch (note the single dot), does it work? If so, I'll commit it. Both . and .. work for me, oddly enough. I wonder if something changed recently with how makepkg works for some people.

nipsky commented on 2019-04-25 13:40

I’m getting the following when trying to install:

patch: **** Can't open patch file ../actiona.patch : No such file or directory

meanjollies commented on 2018-12-01 23:44

@chafic this should build successfully now.

meanjollies commented on 2018-11-30 15:25

@chafic, thanks for reporting this. This seems to be caused after the recent release of opencv-4.0.0-4. I'll look into this further.

Update: Replacing "opencv" with "opencv4" in actiontools/actiontools.pro fixes the failure to detect opencv. Sadly, the actual make process fails due to what appears to be compatibility issues. I've raised an issue with the upstream project.

chafic commented on 2018-11-30 09:57

I get the following error when installing actiona:

Project ERROR: opencv development package not found

meanjollies commented on 2018-05-26 12:34

Building this currently fails after the recent release of Qt 5.11. I have filed an issue upstream.

edit: The upstream dev has fixed this. I've included the fix in the form of a patch, which will be removed once there is a new release upstream.

Admat81 commented on 2016-05-29 11:06

Thank you very much for upgrading actiona to newest version :)