summarylogtreecommitdiffstats
path: root/PKGBUILD
blob: 136bfe28b75913c5d084c698581888a8db71571d (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
97
98
99
100
101
102
103
104
105
106
107
108
109
110
111
112
113
114
115
116
117
118
119
120
121
122
123
124
125
126
127
128
129
# Maintainer: Chris Severance aur.severach AatT spamgourmet.com
# Maintainer: Ainola
# Contributor: Chris Fordham

# This package is designed so that these PKGBUILD are easy to sync with Midnight Commander:
#  aws-cli & aws-cli-git
#  python-botocore & python-botocore-git

# Note: the primary use of this package is with aws-cli

# Use mcdiff to watch for changes
_fn_foobar() {
local _foobar="
#requirements-docs.txt
docutils>=0.10,<0.16
Sphinx>=1.1.3,<1.3
guzzle_sphinx_theme>=0.7.10,<0.8

#requirements.txt
tox>=2.5.0,<3.0.0
nose==1.3.7
mock==1.3.0
wheel==0.24.0
docutils>=0.10,<0.16
behave==1.2.5
jsonschema==2.5.1

#setup.py
requires = [
    'jmespath>=0.7.1,<1.0.0',
    'docutils>=0.10,<0.16',
    'python-dateutil>=2.1,<3.0.0',
]


if sys.version_info[:2] == (3, 4):
    # urllib3 dropped support for python 3.4 in point release 1.25.8
    requires.append('urllib3>=1.20,<1.25.8')
else:
    requires.append('urllib3>=1.20,<1.26')
"
}
unset -f _fn_foobar

set -u
_pyver="python2"
_pybase='botocore'
pkgname="${_pyver}-${_pybase}"
pkgver=1.17.44
pkgrel=1
pkgdesc='A low-level interface to a number of Amazon Web Services. This is the foundation for the AWS CLI as well as boto3'
arch=('any')
url="https://github.com/boto/${_pybase}"
license=('Apache') # Apache License 2.0
_pydepends=( # See setup.py, README.rst, and requirements.txt for version dependencies
  # setup.py
  "${_pyver}-dateutil"'>=2.1' #,'<3.0.0'}
  "${_pyver}-jmespath"'>=0.7.1' #,'<1.0.0'}
  "${_pyver}-docutils>=0.10"  #,'0.16'}
  "${_pyver}-urllib3"'>=1.20' #,'<1.26'}

  # requirements.txt
  "${_pyver}-tox"'>=2.5.0' #,'<3.0.0'}
  "${_pyver}-nose>=1.3.7"
  "${_pyver}-mock>=1.3.0"
  "${_pyver}-wheel>=0.24.0"
  "${_pyver}-docutils"'>=0.10' #,'<0.16'}
  "${_pyver}-behave>=1.2.5"
  "${_pyver}-jsonschema>=2.5.1"

  # requirements-docs.txt
  "${_pyver}-sphinx"'>=1.1.3' # ,'<1.3'}
  "${_pyver}-guzzle-sphinx-theme"'>=0.7.10' #,'<0.8'}

  # old but still required
  #"${_pyver}-bcdoc<0.15.0"
  "${_pyver}-six>=1.1.0"
)
depends=("${_pyver}" "${_pydepends[@]}")
makedepends=("${_pyver}" "${_pyver}-distribute") # same as python-setuptools
options=('!strip')
source=("${_pybase}-${pkgver}.tar.gz::${url}/archive/${pkgver}.tar.gz")
sha256sums=('07e902e82963b98af99606fc58f2d04dfec5b2768209477ac1642c4ee1550574')

if [ "${pkgname%-git}" != "${pkgname}" ]; then # this is easily done with case
  _srcdir="${_pybase}"
  makedepends+=('git')
  provides+=("${pkgname%-git}=${pkgver%%.r*}")
  conflicts+=("${pkgname%-git}")
  source=("${_srcdir}::git+${url}.git")
  :;sha256sums=('SKIP')
pkgver() {
  set -u
  cd "${_srcdir}"
  printf '%s.r%s.g%s' "$(sed -ne "s:__version__ = '\(.*\)'"'$:\1:p' 'botocore/__init__.py')" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)" # "
  set +u
}
else
  _srcdir="${_pybase}-${pkgver}"
#  _verwatch=("${url}/releases" "${url#*github.com}/archive/\(.*\)\.tar\.gz" 'l')
fi

build() {
  set -u
  cd "${_srcdir}"
  ${_pyver} setup.py build
  set +u
}

check() {
  set -u
  cd "${_srcdir}"
  # If pip is installed, some package tests download missing packages. We can't allow that.
  #${_pyver} setup.py test --verbose
  set +u
}

package() {
  set -u
  #depends=("${_pyver}" "${_pydepends[@]}")
  cd "${_srcdir}"
  ${_pyver} setup.py install --root="${pkgdir}" --optimize=1
  install -Dpm644 'README.rst' 'requirements.txt' -t "${pkgdir}/usr/share/doc/${pkgname%-git}/"
  install -Dpm644 'LICENSE.txt' "${pkgdir}/usr/share/licenses/${pkgname%-git}/LICENSE"
  set +u
}
set +u

# vim:set ts=2 sw=2 et: