summarylogtreecommitdiffstats
path: root/.SRCINFO
blob: 553b1b47d44f1827c51ad467137c02024ab33d25 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
69
70
71
72
73
74
75
76
77
78
79
80
81
82
83
84
85
86
87
88
89
90
91
92
93
94
95
96
pkgbase = spyder-git
	pkgver = 4.0.0rc1.r120.gdbc198597
	pkgrel = 1
	url = https://www.spyder-ide.org/
	arch = any
	license = MIT
	makedepends = python2-sphinx
	makedepends = python2-setuptools
	makedepends = python-sphinx
	makedepends = python-setuptools
	makedepends = git
	source = spyder::git+https://github.com/spyder-ide/spyder.git
	md5sums = SKIP

pkgname = spyder-git
	pkgdesc = The Scientific Python Development Environment (Python 2 version)
	depends = python2-atomicwrites
	depends = python2-chardet
	depends = python2-cloudpickle
	depends = python2-jedi
	depends = python2-keyring
	depends = python2-language-server
	depends = python2-numpydoc
	depends = python2-paramiko
	depends = python2-pexpect
	depends = python2-pickleshare
	depends = python2-psutil
	depends = python2-pycodestyle
	depends = python2-pyflakes
	depends = python2-pygments
	depends = python2-pylint
	depends = python2-pympler
	depends = python2-pyqt5
	depends = python2-pyzmq
	depends = python2-qtawesome
	depends = python2-qtconsole
	depends = python2-rope
	depends = python2-sphinx
	depends = python2-spyder-kernels
	depends = python2-watchdog
	depends = python2-xdg
	depends = python2-pathlib2
	depends = desktop-file-utils
	depends = gtk-update-icon-cache
	optdepends = cython2: run Cython files
	optdepends = python2-matplotlib: 2D/3D plotting
	optdepends = python2-numpy: N-dimensional arrays
	optdepends = python2-pandas: DataFrame and Series support
	optdepends = python2-scipy: signal/image processing
	optdepends = python2-sympy: symbolic mathematics
	optdepends = python2-h5py: HDF5 support
	provides = spyder
	conflicts = spyder

pkgname = spyder3-git
	pkgdesc = The Scientific Python Development Environment (Python 3 version)
	depends = jupyter-nbconvert
	depends = python-atomicwrites
	depends = python-chardet
	depends = python-cloudpickle
	depends = python-diff-match-patch
	depends = python-jedi
	depends = python-keyring
	depends = python-language-server
	depends = python-numpydoc
	depends = python-paramiko
	depends = python-pexpect
	depends = python-pickleshare
	depends = python-psutil
	depends = python-pycodestyle
	depends = python-pyflakes
	depends = python-pygments
	depends = python-pylint
	depends = python-pympler
	depends = python-pyqt5
	depends = python-pyzmq
	depends = python-qdarkstyle
	depends = python-qtawesome
	depends = python-qtconsole
	depends = python-rope
	depends = python-sphinx
	depends = python-spyder-kernels
	depends = python-watchdog
	depends = python-xdg
	depends = desktop-file-utils
	depends = gtk-update-icon-cache
	optdepends = cython: run Cython files
	optdepends = python-matplotlib: 2D/3D plotting
	optdepends = python-numpy: N-dimensional arrays
	optdepends = python-pandas: DataFrame and Series support
	optdepends = python-scipy: signal/image processing
	optdepends = python-sympy: symbolic mathematics
	optdepends = python-h5py: HDF5 support
	provides = spyder3
	conflicts = spyder3