summarylogtreecommitdiffstats
path: root/.SRCINFO
blob: d58b5a1d059af4b896e14c1946a19eef3bca8b69 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
60
61
62
63
64
65
66
67
68
pkgbase = postgresql-beta
	pkgdesc = Sophisticated object-relational DBMS
	pkgver = 12beta3
	pkgrel = 1
	url = https://www.postgresql.org/
	arch = aarch64
	arch = i686
	arch = x86_64
	license = custom:PostgreSQL
	makedepends = krb5
	makedepends = libxml2
	makedepends = python
	makedepends = perl
	makedepends = tcl>=8.6.0
	makedepends = openssl>=1.0.0
	makedepends = pam
	makedepends = zlib
	makedepends = icu
	makedepends = systemd
	makedepends = libldap
	source = https://ftp.postgresql.org/pub/source/v12beta3/postgresql-12beta3.tar.bz2
	source = postgresql-run-socket.patch
	source = postgresql.pam
	source = postgresql.logrotate
	source = postgresql.service
	source = postgresql-check-db-dir
	sha256sums = e4a4079c75bf049349c70a02f705beecbb8263684ff2d4e13a582a3ff50332aa
	sha256sums = 8538619cb8bea51078b605ad64fe22abd6050373c7ae3ad6595178da52f6a7d9
	sha256sums = 57dfd072fd7ef0018c6b0a798367aac1abb5979060ff3f9df22d1048bb71c0d5
	sha256sums = 6abb842764bbed74ea4a269d24f1e73d1c0b1d8ecd6e2e6fb5fb10590298605e
	sha256sums = ad025a5fb623b1a1e9dff0cc62cc63f66244bb27d81370a6251aa29e8574be94
	sha256sums = 2bbd8c4e51b70223d274fef3a167af096f44af3d3c41ae505ad11c606674e7c5

pkgname = postgresql-beta-libs
	pkgdesc = Libraries for use with PostgreSQL
	depends = krb5
	depends = openssl>=1.0.0
	depends = readline>=6.0
	depends = zlib
	depends = libldap
	provides = postgresql-client
	conflicts = postgresql-client

pkgname = postgresql-beta-docs
	pkgdesc = HTML documentation for PostgreSQL
	options = docs

pkgname = postgresql-beta
	pkgdesc = Sophisticated object-relational DBMS
	install = postgresql.install
	depends = postgresql-beta-libs>=12beta3
	depends = krb5
	depends = libxml2
	depends = readline>=6.0
	depends = openssl>=1.0.0
	depends = pam
	depends = icu
	depends = libsystemd
	depends = libldap
	optdepends = python2: for PL/Python 2 support
	optdepends = python: for PL/Python 3 support
	optdepends = perl: for PL/Perl support
	optdepends = tcl: for PL/Tcl support
	optdepends = postgresql-old-upgrade: upgrade from previous major version using pg_upgrade
	options = staticlibs
	backup = etc/pam.d/postgresql
	backup = etc/logrotate.d/postgresql