summarylogtreecommitdiffstats
path: root/.SRCINFO
blob: ab46a589c9cf34bf007155035b74e9d021bada97 (plain)
1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
19
20
21
22
23
24
25
26
27
28
29
30
31
32
33
34
35
36
37
38
39
40
41
42
43
44
45
46
47
48
49
50
51
52
53
54
55
56
57
58
59
pkgbase = nvidia-utils-beta
	pkgdesc = NVIDIA driver utilities and libraries (beta version)
	pkgver = 418.43
	pkgrel = 1
	url = https://www.nvidia.com/
	arch = x86_64
	license = custom:NVIDIA
	options = !strip
	source = https://us.download.nvidia.com/XFree86/Linux-x86_64/418.43/NVIDIA-Linux-x86_64-418.43-no-compat32.run
	source = nvidia-drm-outputclass.conf
	source = nvidia-utils-beta.sysusers
	sha256sums = 55cb410c5337f46a48636c2bd5ecb42bf1f4367059394e374b16a8f067de3187
	sha256sums = 089d6dc247c9091b320c418b0d91ae6adda65e170934d178cdd4e9bd0785b182
	sha256sums = d8d1caa5d72c71c6430c2a0d9ce1a674787e9272ccce28b9d5898ca24e60a167

pkgname = nvidia-utils-beta
	pkgdesc = NVIDIA driver utilities and libraries (beta version)
	install = nvidia-utils-beta.install
	depends = xorg-server
	depends = mesa>=17.0.2-2
	optdepends = gtk2: nvidia-settings (GTK+ v2)
	optdepends = gtk3: nvidia-settings (GTK+ v3)
	optdepends = opencl-nvidia-beta: OpenCL support
	optdepends = xorg-server-devel: nvidia-xconfig
	optdepends = egl-wayland-git: for alternative, more advanced Wayland library (libnvidia-egl-wayland.so.1.1.2)
	provides = nvidia-utils=418.43
	provides = nvidia-settings=418.43
	provides = libglvnd
	provides = vulkan-driver
	conflicts = nvidia-utils
	conflicts = nvidia-settings
	conflicts = libglvnd

pkgname = nvidia-egl-wayland-beta
	pkgdesc = NVIDIA EGL Wayland library (libnvidia-egl-wayland.so.1.1.2) for 'nvidia-utils-beta'
	depends = nvidia-utils-beta
	provides = egl-wayland
	conflicts = egl-wayland

pkgname = nvidia-libgl-beta
	pkgdesc = NVIDIA driver library symlinks for 'nvidia-utils-beta'
	depends = nvidia-utils-beta
	provides = nvidia-libgl=418.43
	provides = libgl
	provides = libegl
	provides = libgles
	conflicts = nvidia-libgl
	conflicts = libgl
	conflicts = libegl
	conflicts = libgles

pkgname = opencl-nvidia-beta
	pkgdesc = NVIDIA's OpenCL implemention for 'nvidia-utils-beta'
	depends = zlib
	optdepends = opencl-headers: headers necessary for OpenCL development
	provides = opencl-nvidia=418.43
	provides = opencl-driver
	conflicts = opencl-nvidia