summarylogtreecommitdiffstats
AgeCommit message (Collapse)Author
2021-08-18Add python-pyls-spyder dependencywillemw12
2021-08-18Add dependencieswillemw12
2021-07-10Change pkgname to spyder-gitwillemw12
2020-08-05Add dependencies for version 5.0.0a1willemw12
2020-03-27Add python-parso dependencywillemw12
2019-11-27Add python-intervaltree dependencywillemw12
2019-11-13Re-add pkgbasewillemw12
2019-11-13Remove 'desktop-file-utils' and 'gtk-update-icon-cache' dependencieswillemw12
2019-11-13Remove 'spyder' (python 2 version) from split packagewillemw12
2019-11-13Add cloudpickle and numpydoc dependencieswillemw12
2019-10-05Add pympler dependency. Change source URL from git://... to git+https://...willemw12
2019-07-22Add python*-watchdog and python*-xdg dependencieswillemw12
2019-06-11Add python-diff-match-patchwillemw12
2019-02-15Add dependencies: atomicwrites, keyring, paramiko, pexpect and qdarkstylewillemw12
Note: python2-qdarkstyle is not available
2018-09-27Add chardet and language-server dependencies. Add cython opt-dependency. Add ↵willemw12
extra dependency: python2-pathlib2
2018-09-21LICENSE file is renamed to LICENSE.txtwillemw12
2018-08-05Update description and upstream URL. Remove Qt4 (PyQt4). Add PySide2 ↵willemw12
dependency comments for future inclusion As requested by CAM-Gerlach
2018-07-16Fix typo in the python-spyder-kernels dependencywillemw12
2018-07-06Add python-spyder-kernels and python2-spyder-kernels dependencieswillemw12
2018-01-09Add cloudpickle to dependswillemw12
2017-08-15Switch to dedicated qtconsole and pickleshare packages. Remove .install file.willemw12
2016-08-31Improve pep8 patch. Fix spyder.svg path.willemw12
2016-07-05Rename "pep8" to "pycodestyle" patchwillemw12
2016-07-05Rename python*-pep8 deps to python*-pycodestylewillemw12
2016-04-25Fix nbconvert warning for python 3willemw12
2016-04-18Move 'jedi' and 'rope' from 'optdepends' to 'depends'willemw12
2016-01-30Remove 'ipython-notebook'. Cleanup dependencieswillemw12
2016-01-25Change default from qt4 to qt5willemw12
2016-01-09Remove space character from python2-sphinxwillemw12
2015-12-05Remove python2 patch. Add qtawesome dependency.willemw12
2015-11-21Update dependencieswillemw12
2015-10-04Bump version to upgrade from python 3.4 to 3.5willemw12
2015-09-16Fix 'provides' and 'conflicts'willemw12
2015-08-25Remove optdepends: ipython (already a dependency of jupyter)willemw12
2015-08-25Add qtconsole (depends: ipython2-notebook/jupyter)willemw12
2015-08-25Remove most of the "Python to Python2" patcheswillemw12
2015-06-25Cleanup src/spyder3/ source copywillemw12
2015-06-08Initial commitwillemw12